Question NVMe very slow write speeds Aorus M.2

Mar 10, 2020
3
0
10
0
Hello,

My system:

AMD Ryzen 5 3600X
2x8GB DDR4 G.Skill Ripjaws V 3200mhz
Asus Prime X570-P MoBo
Galax Nvidia GTX-1070Ti
1 x Gigabyte Aorus 500GB NVMe M.2 Generation 4 PCIe x4 in the first slot (Top)
1x Samsung 500GB EVO Plus NVMe M.2 Generation 3 PCIe x4 in the second slot (Bottom)
1x Western Digital 256GB SATA SSD in the SATA 4th port on board
1x Western Digital 2TB 3.5" HDD in the SATA 5th port on board
1x Asus PC-AC88u Wireless adapter in the bottom PCIe 1x slot (Don't use, it is a backup in case my dog chews the Ethernet cable - happened before!)

Problem is, the Samsung EVO Plus is getting ~3200MB read and ~2700MB write, but my Gigabyte Aorus is getting ~5000MB read and only ~500MB write?
The EVO Plus is around 50% capacity and so is the Aorus,
The Aorus is about 2 months old and the EVO is 2 weeks old,

The speeds of the Aorus are NOWHERE near the specs of what it should be... I ran a CrystalDiskMark 7 bench on the Aorus about a week or more ago and the write speed was about 1200MB and over the last week it has dropped to about 500MB, this is from benches of 32MB up to 16GB,

When I first got the drive in January things were GREAT! Amazing speeds that were blasting my old 256GB SATA drive out of the water, now I am installing programs or games and the speed drop is totally noticable in real world applications as well as benches....

Please help as I just built this PC in January coming from an ancient 8 year old setup and really want the best that I can get for this "Semi-Budget" build,

Cheers,



Ben

PS. Attached a screenshot of Samsung Magician as it gives the same results and more info than CrystalDiskMark 7

PSS. The 5th drive is a USB flash drive

 
Mar 10, 2020
3
0
10
0
Please help.... this is REALLY bugging me, tried BIOS, tried drivers (none are apparently more up to date even though the drivers are from 2006?!?!), tried the Gigabyte software and that has pretty much NOTHING to say about the whole ordeal or anyway to improve things, I trim my drives with Windows 10 DAILY... seriously... at least check my system for me and tell me I need to RTB the device?

Interestingly, all the Gigabyte Aorus drives that were being sold by my reputable components supplier have disappeared from their site...
 

Maxxify

Distinguished
Aug 12, 2007
423
74
18,990
34
I've seen people with this problem who solved it with a firmware update, but that's not always an option. Be aware that those speeds are NOT abnormal for the base TLC. At 500GB the TLC on this is probably ~600 MB/s with folding speeds closer to ~300 MB/s. Also, NVMe drives don't require drivers with Windows 10. Check the link in my signature if you want to learn more about these concepts, however it's not uncommon for people to buy 4.0 drives without realizing they're slower than 3.0 drives outside the cache in many cases.

The cache on these drives is quite large so you shouldn't dip outside of it normally, however drives with caches like this (large, dynamic) have the tendency to get stuck in slower modes because of predictive algorithms and the nature of pSLC (i.e. TLC in single-bit mode has to be converted back and forth). A secure erase or sanitize will usually return it to factory state, if it persists you require a firmware update or replacement.
 
Mar 10, 2020
3
0
10
0
Thanks for the reply Maxxify,

When I got home from work today (Just now) I started Chrome - put some music on, performed a 20GB update of CoD:MW, then thought I would test it again for giggles,

Showing 2529.58MB/s with a very short 2 pass 32MB bench...

I did muck around with BIOS on boot though, changed 4 DIGI+ VRM options from Extreme to Auto?
 

ASK THE COMMUNITY