[SOLVED] Old Intel C2Q Processor Question

box o rocks

Distinguished
Apr 9, 2012
561
3
18,985
0
I read here that the old AMD Phenom II CPUs lack some instruction set (or something) that would allow them to run certain modern games. What about older Intel CPUs from the Core 2 era? Core 2 Quads in particular. Do they suffer from that same lack?
 
that would be incorrect
4.0 is for core 2
4.1 is for nehalem
4.2 for haswell

games themselves doesnt need 4.x instructions
but depends on which DRM it has (copy protection) it may fail to run, unless u get DRM free version, or cracked, or game which made updates to denuvo to remove 4.x requirement (only few games got those updates)
 
Last edited:
any game with dx12 utilises avx/avx2, dispatcher will just enable/disable its not required to have, some apps have precompiled avx executables (hand made optimisations)

sse4.1 hmm, its denuvo than

Denuvo version 5.0 requires your CPU to support instruction sets known as SSE 4.1 and 4.2

get DRM free games (from GOG.com), no sse4.x needed then
 

box o rocks

Distinguished
Apr 9, 2012
561
3
18,985
0
OK. So then the consensus is that no matter the exact technical reason, the old Intel C2D and C2Q are in the same situation as the old AMD Phenom IIs when it comes to running modern games, yes?
 
that would be incorrect
4.0 is for core 2
4.1 is for nehalem
4.2 for haswell

games themselves doesnt need 4.x instructions
but depends on which DRM it has (copy protection) it may fail to run, unless u get DRM free version, or cracked, or game which made updates to denuvo to remove 4.x requirement (only few games got those updates)
 
Last edited:

box o rocks

Distinguished
Apr 9, 2012
561
3
18,985
0
that would be incorrect
4.0 is for core 2
4.1 is for nehalem
4.2 for haswell

games themselves doesnt need 4.x instructions
but depends on which DRM it has (copy protection) it may fail to run, unless u get DRM free version, or cracked, or game which made updates to denuvo to remove 4.x requirement (only few games got those updates)
So, now I need to look for the min req for every individual game if I want to continue using a Core2 or Phenom II? Or do your above work-arounds?
 

j121

Respectable
Nov 9, 2017
654
49
2,040
23
if your looking for a used system get at least 1155 system with intel core i5 2400 , 2500 or a i7 2600. recommend to upgrade hp pro 3500. check ebay for used market they can also handle intel xeon e3 1270 that is about same as intel core i7 2600.
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts