Question PC booting up but does not output display

Aug 16, 2019
5
0
10
0
Hello. Earlier today I had some blue screen issues and I tried many things to solve them, including re-attaching my RAMs. I made the mistake of placing the first one upside down with some pressure but not too much. I fixed it and did the second one properly. After that, I tried to boot up and even though the system powered on, I got no display on my monitor. I tried changing my RAMs to the other two slots and also tried removing one of them but nothing worked. At first I thought I messed up that one ram slot on the motherboard but the others also do not work. If anybody has any idea on what to do I would really appreciate it.
Here is a list of my components (which are quite old).

Asus M5A99FXPRO R2.0 Motherboard
AMD FX 8350 Processor
Kingston HyperX Beast DDR3 RAM 2X8GB
Sapphire Radeon R9 270X GPU
Corsair CX 750M PSU
NZXT H440 Case

Thank you in advance.
 
Last edited:
Aug 16, 2019
5
0
10
0
Have you cleared the CMOS?
Yes I did clear it with the instructions written on the motherboard's manual. If it helps, there is a DRAM led on the motherboard that is turned on, which means that the RAM is not recognized. Also I've used this system for 6 years, it's not a new build. Thanks for any help
 
Yes I did clear it with the instructions written on the motherboard's manual. If it helps, there is a DRAM led on the motherboard that is turned on, which means that the RAM is not recognized. Also I've used this system for 6 years, it's not a new build. Thanks for any help
Unplug your computer again, clear the CMOS for at least 30 seconds and put just 1 stick of RAM in slot DIMM_A2. Plug the power back in and reboot.
 
Aug 16, 2019
5
0
10
0
Thanks for your time. I just solved it by pressing the RAM extremely hard until it clicked a second time. I thought it was supposed to click only once, when securing the top part (as it is displayed on the manual...) I feel a bit stupid, thank you very much anyways!
 

ASK THE COMMUNITY