[SOLVED] pc crashing and slow after attempted new gpu driver download

Apr 14, 2021
2
0
10
0
Recently I bought a 2nd hand gtx 970, but when I plugged it into my motherboard and tried to download its drivers, my pc got extremely slow and eventually crashed. This kept happening after restarting multiple times.
But now even without the 970 plugged in, my pc is extremely slow and crashes.
I would love any help with this issue...
Thanks

PC SPECS
motherboard: ga-b85m-hd3
cpu: i7 4790
ram: 12gb ddr3
psu: cooler power P4N8-N 750W
gpu: EVGA gtx 970
 
Recently I bought a 2nd hand gtx 970, but when I plugged it into my motherboard and tried to download its drivers, my pc got extremely slow and eventually crashed. This kept happening after restarting multiple times.
But now even without the 970 plugged in, my pc is extremely slow and crashes.
I would love any help with this issue...
Thanks

PC SPECS
motherboard: ga-b85m-hd3
cpu: i7 4790
ram: 12gb ddr3
psu: cooler power P4N8-N 750W
gpu: EVGA gtx 970
As for GPU drivers, use DDU https://www.guru3d.com/files-details/display-driver-uninstaller-download.html to uninstall any old drivers and then try to install newest ones.
 
Reactions: swagtheduck
Recently I bought a 2nd hand gtx 970, but when I plugged it into my motherboard and tried to download its drivers, my pc got extremely slow and eventually crashed. This kept happening after restarting multiple times.
But now even without the 970 plugged in, my pc is extremely slow and crashes.
I would love any help with this issue...
Thanks

PC SPECS
motherboard: ga-b85m-hd3
cpu: i7 4790
ram: 12gb ddr3
psu: cooler power P4N8-N 750W
gpu: EVGA gtx 970
As for GPU drivers, use DDU https://www.guru3d.com/files-details/display-driver-uninstaller-download.html to uninstall any old drivers and then try to install newest ones.
 
Reactions: swagtheduck
Apr 14, 2021
2
0
10
0
Ok so after getting rid of old drivers I downloaded a core temp and noticed that my cpu was running at 100 degrees... So I pulled my cooler off and cleaned a tonne of dust off it. Booted my pc and i'm no longer having issues...

tldr: cpu cooler just needed a damn clean
 

ASK THE COMMUNITY

TRENDING THREADS