PC keeps crashing at boot up and randomly due various different BSODs

MantasMM

Prominent
Jun 5, 2017
6
0
510
0
Half a year ago I built my own PC, I'm no tech mastermind but I put everything together and everything works fine except ever since I put my PC together it crashes due to some BSOD, sometimes while I'm gaming or just browsing the internet my PC crashes and then follows up with predominately a MEMORY_MANAGEMENT BSOD (sometimes different ones) and up until a few months ago it also started crashing when booting due to one of many different BSODs (but then it restarts and I can use my PC normally)

All of the BSODs I have gotten:
-MEMORY_MANAGEMENT
-KERNEL_SECURITY_CHECK_FAILURE
-SYSTEM_SERVICE_EXCEPTION
-SYSTEM_SERVICE_EXCEPTION_NOT_HANDLED
-IRLQ_NOT_LESS_OR_EQUAL
-BAD POOL HEADER
-BAD POOL CALLER
-PAGE_FAULT_IN_NON_PAGED_AREA

I also used windows driver verifier and it yielded many of the similar BSOD as I'd get booting up
I've run memtest86 twice, it says my memory is working fine
I've run sfc scannow to check my drives, they're also fine
I've also reset my PC several times, yielding no fix to the crashing, I've looked up solutions to these BSODs and tried many but had no luck

Thank you for taking your time to read this, I've never posted something like this before but I really need help since I can't find a solution on my own
 

Zerk2012

Titan
Oct 6, 2014
14,063
0
73,160
3,689
you ran memtest twice so you mean 2 passes?
memtest should be ran at least 8 hours would even be better to start it when you go to bed and stop it the next day when you get home from work.
You should list all your hardware but a good place to start is to double check your memory timings, speed, and voltage in BIOS to make sure it's set to the memory specks. From their I would add 0.02 volts to the memory.
If your using memory that was not bought in a matched set (ever how many sticks sold in one package) this could also be a problem but adding the extra voltage could cure it.
 

MantasMM

Prominent
Jun 5, 2017
6
0
510
0


Thank you for your reply,
I checked my ram timing, voltage and speed are all running at what they should be, I also added the 0.02 volts to the memory, I'm not sure if this helped yet as my PC still crashed on boot due to a -BAD POOL HEADER
I got two 8gb sticks of ram from the one package
Here are my specs:
Motherboard: MSI Z170A Tomahawk
GPU: MSI GTX 960 2gb
CPU: i5 6600k
RAM: Crucial Ballistix Sport 2x8gb ddr4
SSD: Samsung 850 evo
HDD: Western Digital WD Blue 1TB

I will try running memtest tonight, presuming my ram is working fine, anything else that could be causing all these BSODs?
 

Similar threads