Question PC not booting up

Dec 8, 2020
4
0
10
0
My PC recently had a fall (won't go into details) and when I then went to start it up, unsurprisingly, it wouldn't boot. The fans starts spinning, LEDs etc came on and it then died.
Once I got back from work I tried again with the PC showing no life except a fan LED flashing.
I unplugged RAM and tried resitting in different slots. Unplugged fan headers, GPU and still nothing.
I then had nothing except my CPU in, everything else was plugged in apart from the ATX 12v 8 pin and the CPU fan and it then flashed into life only to then suddenly die and go into a boot loop. I assumed this was due to the system not wanting to do to much as the cpu cooler wasn't plugged in. After plugging this in, same results. I then tried plugging in the 12v 8 pin and then it reverted back to the lonely LED fan flashing and nothing more.
I'm thinking this is a motherboard issue as the PSU seems to be working. Any thoughts?

Thanks
 
Dec 8, 2020
4
0
10
0
Just as an observation, your combination of RAM sticks is not the best.
Mixing different sizes like that is a recipe for problems.
As a rule you should not use mismatched RAM sticks.
Yeah I know this, I only got these as I upgraded my last setup and just bought a single 8gb DIMM, I was going to replace it but never got around to it.
It has been working fine for around 2 years or so
 
Dec 8, 2020
4
0
10
0
Update:
I've removed my motherboard from the case to check for grounding issues.
Removed the cpu and re-seated it. Same results, bootloops without the 12v 8 pin as there's no power to the CPU, when I plug it in, nothing except a flash.
I can only guess that my CPU is now dead?
 

ASK THE COMMUNITY

TRENDING THREADS