Question PC shuts down after a while, also a YELLOW and a WHITE screen

telgou

Honorable
Jun 17, 2015
18
2
10,515
0
Hey, yesterday i started using my old pc.
I think i cleaned any dust that could make the pc stop working, also i removed and put the RAM sticks again (since the pc was in a booting loop, it happened before)

But after i fixed that problem, a new problem came up. After a while(+1 hour) running the pc shuts down (and doesn't reboot) i was not paying attention so i didn't see if there was an error or something.
Now i turned it on, i got a yellow screen just after a while. Started it again, i got a white screen after a while.

CPU temperatures are very low (45-77 under stress)
I have no dGPU, just using the iGPU. Could it be the iGPU dying somehow for no reason ? since i get these screens ?
I don't know about the PSU, it's a suspect too.
I am afraid of turning it on again and getting a new colour after a while...
 

telgou

Honorable
Jun 17, 2015
18
2
10,515
0
Temps or PSU would be suspect, and seems like temp is good. Need to know make/model of PSU, or picture of label
Yeah temps for everything are good, though i don't think i checked the PSU temperature.(i think CPUID HWMONITOR didn't even detect it... in case it can)

My suspicion(and yours) may be right... it may very well be the PSU. I just tried to turn it off using its own button and i heard a short crackling electricity sound as i was pressing it... either it got too old or maybe a dust problem ?

It's not from a known brand, so no wonders. I used this pc for 3 years 2013-2016, then very few times from 2017 to 2019.
It's a OCZ ModXStream 700w...
 

ASK THE COMMUNITY

TRENDING THREADS