Question PC will turn on for 10-20 seconds before turning off and restarting

Dec 6, 2020
5
0
10
0
Hi there, I recently bought a ryzen 5 3600x and Asrock b450m pro4. When I tried installing it with the rest of my components, It would start and all the fans would run, but it would turn off after 10-20 seconds. before turning on again. I tried testing this with just the motherboard,CPU, RAM and graphics card with the same outcome. I tested it outside the case to rule out the motherboard shorting on the case/risers.

I haven't used any of the other components in a couple of years, so I don't know if any of them have gone bad. One other thing I noticed is that the case fan connected to Chassis fan1 would spin, but the one connected to chassis fan2 would not. I don't know if this is related to the issue or part of the default BIOS settings. CPU and graphics cards fans would both spin. I didn't get any output on the monitor (connected to the gtx 1060). Any help would be greatly appreciated. Thanks!

Ryzen 5 3600x (new)
Asrock B450m pro4 (new)
GTX 1060 3GB (old)
Crucial ballistics sport 8GB (old)
CoolerMaster lite 500w(old)
HDD is a 1TB WD Blue, and I also tried turning the board on with a screwdriver to rule out the possibility of my case switch getting stuck.
 

kurdtnz

Notable
Feb 24, 2020
941
139
1,090
22
Sounds like the issue is pointing towards a faulty psu? (but do wait for someone more experienced to confirm.) Also, unless your motherboard is 'Ryzen 3000 ready,' It will need a bios update to run a 3rd gen cpu.
 
Dec 6, 2020
5
0
10
0
Thanks for the response. my motherboard is 'Ryzen 3000 ready.' I'm doubtful its the psu, but seeing as I don't have another working board I can test (old one is busted), I can't really be sure about that.

Edit: it does seem like the motherboard was the issue, as I threw everything onto an a320m and it worked perfectly.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS