Question PC wont start when using Dual Channel RAM

Mar 8, 2019
8
1
15
0
SPECS:
Motherboard: Biostar G41D3C Ver.7.x
CPU: Intel Celeron E3400 2.6Ghz (2 Cores)
RAM: G.SKILL Value Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10666)
Previous RAM: 2GB DDR3 ADATA 1333Mhz (AD3U1333C2G9-S 2GX8 U-DIMM)

Recently I bought a ram upgrade for my old PC, the PC only had 2GB of ram Single Channel. I got 2 new ram sticks of 4G to make 8GB in Dual Channel.
The problem is, the PC wont boot at all when I use both sticks at the same time. It just freezes in the post screen or goes all blank(like if the video signal was getting unstable).

I already tried using each stick individually and in both slots and they work fine, the problem is when I use both slots at the same time. The motherboard is supposed to support 8GB of ram(each slot supports 4GB stick). Im not sure but this could be a voltage issue, or maybe I have to enable a specific option in the BIOS for dual channel support(wich I havent found yet). The MOBO also supports dual channel.

Any tips or advices are welcome.
 
Mar 8, 2019
8
1
15
0
UPDATE:
Something weird happened, I used the old 2GB stick and a 4G stick at the same time and it booted without a problem. The problem only seems to happen when I use both 4GB sticks.

Any idea why this is happening?
 
Mar 8, 2019
8
1
15
0
One of the 4gb sticks may be faulty.
I already tried both 4Gb sticks individually and they work fine, I think this can be a problem with the motherboard itself, or maybe the PSU is not working correctly and the motherboard is not getting enough voltage.

Another weird thing is, the first time I tried using both RAM slots, it worked and I got 8GB of ram (I didn't have access to all ram because I had Windows 7 Home 32bit), and after I rebooted to install windows, the problem started to happen, maybe the problem can have something to do with the bios? I will still try to get both 4Gb sticks to work in the meanwhile.
 

ASK THE COMMUNITY

TRENDING THREADS