Question pc wont turn on is my mobo dead or psu?

Nov 29, 2019
6
0
10
0
CPU: ryzen 5 2600
GPU: vega 56
PSU: corsair cx (2017) 650w
mobo: MSI tomahawk max
ram: corsair vengeance cl15 3000mhz
harddrive: Seagate barradacompute 2tb
SSD: integral p 240gb

it all started when I finished my new build yesterday then when I went to turn it on, it went on for a split sec then turned off so I left it for like 1hr so then when I came back it would not turn on at all so then I tried just plugging in the PSU to my Molex fan and it would not turn on so now I think its the PSU but however I think my mobo might be fried so I can't tell I have already tried plugging in the CPU 8pin and CPU fan and 24pin by its self and the PSU still would not spin so maybe my mobo is fried or PSU is broken so any suggestions?

EDIT: PSU model is 9020122-UK
EDIT 2: PSU works I tried the PSU paper clip test now I think my mobo is fried however why did my PSU not work with just one of my Molex fans plugged in?
 
Last edited:
Nov 29, 2019
6
0
10
0
Try resetting CMOS, if that doesn't work, try another psu, if it's too weak take out your gpu and put in a low end model.
I have already tried taking out the gpu and just power it on but i have not reset the cmos battery yet however my fan should have turned on when i just plugged it in by its self to the psu yet it did not turn on and how do i reset the cmos battery i have already taken it out and put it back in id that resetting it?
 

ASK THE COMMUNITY

TRENDING THREADS