Problem with my new Sapphire Nitro+ RX580 OC

Jan 17, 2019
7
0
10
0
Hi everyone. This is my first thread here, because after months using this website, I had to sign uo in order to be able to create posts (Sorry about my english).


So, I just changed my GPU from a GTX 1050ti (0 noise, 0 heat) to a RX 580 (very hot compared to GTX 1050ti and very noisy).

My PSU is an Aerocool KCAS 500W Bronze Plus, so I supposed that my PSU is ok for my setup (The official Sapphire website suggest a minimum of 500w psu, so...)


When I was using the 1050ti everything was ok, but once I plugged in the new one, when Im gaming, my computer makes a very annoying sound (coil whine). In fact, there are moments that the gpu freezes so my gameplay is not smooth. Im not sure from where the sound is coming from, but I suppose that is comming from the GPU. If the gpu is not powered properly (I mean: the gpu is getting less watts than what it needs) can produce coil whine or it´s not related?


Many people say that changing the PSU will be OK, but others says the opposite, so I dont know what to do. I think Im gonna replace my RX580 for another one and try it. If the sounds keeps buzzing, It will be the PSU.


What do you think, guys? (Once again, hope you understand me, I dont speak english)
 
Jan 17, 2019
7
0
10
0


I wanna replace the gpu or the psu but I dont know what to replace. Both are in warranty, so it would cost 0 euros for me. But thats the question, psu or gpu?

When Im playing, the gpu freezes in the same moment as the sound disappears, something like the coil whine and freezes are in sync
 

ASK THE COMMUNITY

TRENDING THREADS