Problem with upgrading RAM

I have an older PC in the house and it had 1x 2GB RAM PC 6400 in it.

I jotted down about 8 different numbers clearly written on the RAM stick and went online and found another RAM stick from the same company with the same exact part number and all the other numbers the exact same.

These things might as well be the same physical ram stick they are that similar.

Anyway, I put it in and turned the PC on and it turned on, turned off, turned on, turned off, turned on, turned off.

After watching it do that 3 times I turned it off with the power button and took out the new RAM.

I turned it on again. It booted just fine.

I turned it off again and stuck in the new RAM again. Then I took out the battery for a while and put it back in and I turned it back on.

Now the computer turns on just fine, but there is never a display.

The computer fans are on and everything but it never reaches the screen to press a key for BIOS.

All cords are securely fastened, I double checked.

I don't want to believe this is a bad RAM slot or a bad RAM stick. That just sounds too unlucky even for me.

Anyone else have an explanation that isn't one of those two things?

I will toy around with it a bit and come back with more info shortly.

- Edit - I took the power cord out of the back of the computer and then stuck it back in. The computer now turns on when I do this. I don't have to hit the power button to turn the computer on anymore. Just flipping the switch in the back to disallow power or reenable power will also turn the computer on now. Still no display. The computer is supposed to wait until I hit the power button before it comes on...

- Edit 2 - Took out the new RAM again. The computer still comes on when I put the power cord back in now, but it will boot with a display again without the new RAM. Will toy around with it some more.

- Edit 3 - Took the new stick out, messed around with some BIOS settings to disable quick POST and stuff and then put the stick back in. The computer went back to the start, stop, start, stop, start, stop thing. Then I turned it off and took all the RAM out and put only the new stick in the old Slot 1. The computer is turning on and has POSTed. It is running a regular startup RAM check on it now, but there IS signs of life with the new RAM.

- Edit 4 - I downloaded a program called MemTest from a company called HG Design and I am running 6 copies of it from within Windows XP on the old machine. The new RAM is still in slot 1. When the computer turned on, it told me something weird, though. It seemed to think the RAM was 667 RAM instead of 800 RAM for some reason, even though 800 is written on the stick itself. It seems like the motherboard wants to downclock the new RAM for some reason. The MemTest program has yet to turn up any actual errors, though. Even if it wanted to run this RAM at 667 mhz I don't see why it wouldn't just run both sticks at 667 instead of turning the computer off and on over again.

- Edit 5 - MemTest(s) still running, nothing found yet on the stick.

- Edit 6 - Turned off the PC, took out the new RAM. Compared new RAM information to the information on the box that the new RAM came in. It doesn't appear to be the wrong RAM getting put in the box. Compared the old RAM to the box, seems to be the same. Compared the new RAM to the old RAM, seems to be exactly the same. Put the old RAM back in and started the computer. The readings seem to be exactly the same as the new RAM. The RAM was clocked at 667 instead of 800 like the new one with a lot of other stuff nobody probably cares about. TCL: 5, TCRD: 4, TRP: 4, TRAS: 12 (2T Timing).

- Edit 7 - So I had the bright idea that the PSU might just not be able to handle the tiny extra load from the new RAM chip and I switched out the PSUs with a PSU from a system with 3x the draw and... it still restarts itself.

- Edit 8 - I took the battery out again and put both the sticks in and put the battery back in, now it will turn on without restarting, BUT it just freezes at the manufacturer splash screen.

- Edit 9 - I took one of the sticks out and it will boot again, I again changed a couple BIOS settings (obviously my previous changes were lost when I took the battery out) and I turned it off again, then I put in the second stick again and turned it on and it is showing some signs of life. I have it running a memory test at the moment. It hasn't restarted on me yet like it was doing before every 2 seconds.
I fixed it myself.

Just a whole bunch of times of messing around with it, taking the battery out for 15 min, putting it back in, messing with settings and so on, failing, repeating all that again.

I can't think of anything I did different to make it work the last time other than praying. I did that the last time right before it worked.