[SOLVED] Question with Ryzen 7 5700g

Feb 2, 2022
4
1
15
0
Hello everyone I have a question


Can anyone confirm that this CPU is 100% compatible with the following mobo: Asus Tuf gaming b450-m plus II??? In the website it says compatible but as soon I update igpu drivers I start to have random black screens and freezes. I Made the test with a a520 ds3h mobo with the same problem. The store technician said that is a vrm problem and I have to Buy a x570 mobo at least. Please help. 😢
 
Did you enabled the DOCP or XMP in the bios, if so, make sure its off and then see if the system will be stable after that.

I just built a 5700G system for my uncle on a b550 board, had to flash the bios on it as well to get it to work with the CPU, then we had issues with the bios not loading like the resolution the bios was outputting threw his GTX 1070 was not compatible with that monitor, then we had issues with the RAM, it would not run at 3200mhz, all I did was swap 2 of the 4 sticks around and it runs at 3600 overclock stable as can be now, idk, maybe it wasn't seated into the slots good enough.

Maybe try re seating the CPU and ram into the slots and se if it works.

Good Luck!
 
Reactions: Dicat and kurdtnz

kurdtnz

Estimable
Another 'store technician' giving bad advice.... The board will run the 5700G but the BIOS needs to be updated to at least version 2409. Luckily that motherboard has BIOS flash so it is easier to update using a usb stick. If you have never updated a BIOS before, there are many videos out there that will show you how to do it,(probably a few for that specific motherboard too.) Watch and research as much as you can until you are comfortable enough to do it.
 
Reactions: Dicat
Feb 2, 2022
4
1
15
0
Thanks for your reply, But I forgot to mention that I have tried everything, Bios are up to date, I tried several Radeon software versions, I tried different RAM, PSU, hard drive and Windows versions (all 10s and 11), different motherboard, Even monitors and HDMI cables But no luck.., as soon I update the igpu the black screens occurs. Sometimes with an AMD driver timeout error or sometimes with a bsod with a TDR failure error. I don't know what else to do to be honest. It's very frustating for My first build :(
 
Last edited:
Reactions: kurdtnz
Did you enabled the DOCP or XMP in the bios, if so, make sure its off and then see if the system will be stable after that.

I just built a 5700G system for my uncle on a b550 board, had to flash the bios on it as well to get it to work with the CPU, then we had issues with the bios not loading like the resolution the bios was outputting threw his GTX 1070 was not compatible with that monitor, then we had issues with the RAM, it would not run at 3200mhz, all I did was swap 2 of the 4 sticks around and it runs at 3600 overclock stable as can be now, idk, maybe it wasn't seated into the slots good enough.

Maybe try re seating the CPU and ram into the slots and se if it works.

Good Luck!
 
Reactions: Dicat and kurdtnz
Feb 2, 2022
4
1
15
0
Thanks for your reply, DOCP is disabled, already swapped the ram sticks and tried every slot individually with both sticks, same problem. My ram is 2x8gb g.skill ripjaws 3600mhz btw.
 
Feb 2, 2022
4
1
15
0
I solved the problem, it was the ram, not sure if faulty or not compatible ( it worked in My friend's PC).
 

ASK THE COMMUNITY