Question R5 3600 @90+ deg

sky_lar

Reputable
Nov 6, 2016
13
0
4,510
0
I constantly getting 50-70 degrees on idle and 90+ degrees on load. I know 50-70 deg is just fine but on idle its just bad.
I didn't overclock my processor.
I am using a hyper tx3 evo since my stock cooler randomly stopped working and the thermal-paste that comes with it the hyper tx3 evo.
My case has good airflow and my gpu does just fine.
Should change my cooler or something ?
 

Sohom

Respectable
Mar 6, 2017
1,016
20
2,665
181
did u clean the older thermal paste before putting on the new cooler? u can try changing the thermal paste; i wud suggest the coolermaster mastergel maker...
 

Phaaze88

Dignified
Herald
Most likely a bad mount.
Push pin coolers are a pain in the butt due to how easy it is to screw up the installation.

Once again, remove the old paste and reapply new. Mount the cooler in an X formation:
-top-left + bottom-right pin at the same time. They must CLICK.
-top-right + bottom-left pin at the same time. The CLICK is important.

If you did it right, you shouldn't see idle temps of 50C+.
 

sky_lar

Reputable
Nov 6, 2016
13
0
4,510
0
Most likely a bad mount.
Push pin coolers are a pain in the butt due to how easy it is to screw up the installation.

Once again, remove the old paste and reapply new. Mount the cooler in an X formation:
-top-left + bottom-right pin at the same time. They must CLICK.
-top-right + bottom-left pin at the same time. The CLICK is important.

If you did it right, you shouldn't see idle temps of 50C+.
I am using am3+ mount u might have a better understanding of what am talking about here: https://www.coolermaster.com/catalog/coolers/cpu-air-coolers/hyper-tx3-evo/
 

ASK THE COMMUNITY

TRENDING THREADS