Question Random black screen 'crashes' while playing games after installing a new PSU?

Oct 10, 2020
5
0
10
0
System:
-b450 tomahawk max
-ryzen 7 3700x (arctic 7 pro heatsink)
-asus strix 970
-Corsair vengeance pro 3200mhz
-Corsair TX750M psu
-3tb seagate HDD
-1tb m.2 as boot drive


So recently i ordered a new gpu to replace my 970 and needed to also upgrade my old 500w psu to a new 750w psu. I decided on the TX750m and installed it accordingly in preparation for my new gpu. However, since then i have been getting random black screens while playing games.

The first time it happened, maybe 1-2 weeks after installing my new psu, i was playing a game when suddenly both of my monitors flickered and then went black and then turned off as if there was suddenly no signal being displayed. I could still hear the game sound and my music playing but the screens wouldnt come back on until i hard restarted the PC. This got worse and worse over a week until i couldnt turn my pc on without the screens going black as soon as windows booted.

So i reinstalled windows and then the problem stopped. However, today it happened twice again, both times while in games. I haven't played a game since then as i dont want it to get worse but i no longer know what the problem may be.

I have reinstalled windows, bought new ram (i originally thought it was that), does a windows ram test, check both my drives and checked all the cables and connections in my pc. I highly doubt it is any other component than my psu or gpu as everything else has been working perfectly for the year since i got a new mobo and cpu and the problems only started after my new psu was installed.

However, i also doubt it is my psu and surely the whole pc would turn off and not just the screens if it was faulty and power consumption seems to be normal. Which only leaves my gpu.

Is it possible my gpu has betrayed me just weeks after ordering a new gpu?
 

PC Tailor

Judicious
Ambassador
surely the whole pc would turn off and not just the screens if it was faulty and power consumption seems to be normal
Not so. Random restarts are certainly indicative of a power issue, however it does not always result in full restarts. If there is ripple or insufficient/inadequate power being delivered to the GPU, the GPU can beging to show what you describe, even though it is the power delivery behind it that's the problem.

Initially I would have suspected your GPU first, but you're stating that you haven't even got the new GPU yet and you're still using the old one that has worked perfectly fine until you changed the PSU?
 
Oct 10, 2020
5
0
10
0
Not so. Random restarts are certainly indicative of a power issue, however it does not always result in full restarts. If there is ripple or insufficient/inadequate power being delivered to the GPU, the GPU can beging to show what you describe, even though it is the power delivery behind it that's the problem.

Initially I would have suspected your GPU first, but you're stating that you haven't even got the new GPU yet and you're still using the old one that has worked perfectly fine until you changed the PSU?
Correct, i ordered a TUF OC 3080 so i wont get it for a while and i have been using my 970 since 2016 with no issues until after i installed my new psu. The screens only go black after playing games for a while too.
 
Oct 10, 2020
5
0
10
0
A lot of work that will help you confirm what the issue is.

If the issue disappears with the old PSU installed, I'd return the new PSU and just get a warranty replacement, not common for TXM to be DOA.
True, i will have to try and find time this week to do that and see if it changes anything. I'll update this thread after i've done that, thanks for you advice.
 
Oct 19, 2020
5
0
10
0
I have the exact same issue dude!! after playing cod, overwatch or genshin impact goes black screen I have being experiencing this after a clean up maintenance done to it and i suspected of the psu ... seems to have a electric contact issue to it cuz once i disconnected all cables and reconnected them back and that problem was solved for 4 weeks and then it came back
 
Oct 10, 2020
5
0
10
0
A lot of work that will help you confirm what the issue is.

If the issue disappears with the old PSU installed, I'd return the new PSU and just get a warranty replacement, not common for TXM to be DOA.
Hi, this has taken a while but I managed to get the new power supply replaced so I contacted Corsair and got it RMA'd. In the time between returning it and receiving the replacement, I have been using my old PSU and encountered no problems, the black screen issue was fixed.

However, today I received the replacement, installed it and played some games. As I feared just 2 hours in it black screened again and automatically rebooted. Is it possible that I have gotten 2 DOA PSUs in a row or is it likely another issue separate from the PSU but triggered by a high power pool?
 

ASK THE COMMUNITY

TRENDING THREADS