Question Red Devil RX580 8gb crash

Sep 9, 2019
8
0
10
0
My screen is always freeze whenever I play game (Monster Hunter World). But the sound is still there. Sometimes it freezes on the start screen. And theres time when I restart my computer and it stucks on Windows logo. It only happens when I played game. I tried to run stress test using furmark but there is no problem. No crash no freeze. I tried using latest driver only to receive Wattman error message after restarts. The problem also occurs when I’m on older driver. I dont know what to do anymore. My spec is as below:

Ryzen 5 2400g
Asrock AB350M HDV
Apacer Panther 2x8gb 2400mhz DDR4
120gb SSD
Red Devil RX580 8gb
Silverstone ST50F-ES230 500W
 
My screen is always freeze whenever I play game (Monster Hunter World). But the sound is still there. Sometimes it freezes on the start screen. And theres time when I restart my computer and it stucks on Windows logo. It only happens when I played game.
Does this happen ONLY when playing Monster Hunter World, or even other PC games as well ? IF other game titles are running fine/smoothly, then most probably it might be an issue related to the Game itself/MHW.

What's the GPU/CPU temp value while Gaming ?
 
Sep 9, 2019
8
0
10
0
Does this happen ONLY when playing Monster Hunter World, or even other PC games as well ? IF other game titles are running fine/smoothly, then most probably it might be an issue related to the Game itself/MHW.

What's the GPU/CPU temp value while Gaming ?
Other game as well, CS:GO and Jump Force to be exact. Temp for both around 65 during gaming.
 
Sep 9, 2019
8
0
10
0
Have you run a system RAM test to see if one of your sticks of RAM is faulty?

Is the whole system the same vintage? Or was the system running/gaming fine before you added the GPU?
Yup tested the ram and everything is fine. Before this gpu, I’ve been using the integrated graphics and there will be BSOD with atikmpag.sys error
 
Sep 9, 2019
8
0
10
0
What program did you use to test the RAM and how long did you run the test?
I used memtest86. I’m not sure how long the test was because I ran the test way before I use RX580. Is it possible that the ram is the problem?

And I tried to run the game with lowest resolution and no crash occurred except there is screen tear.
 

ASK THE COMMUNITY