• Enter here for a chance to win a custom MechWarrior 5: Mercenaries themed PC powered by Intel!

Question Red light for CPU and DRAM randomly after PC shutting down

ptK47

Prominent
Dec 3, 2019
7
0
510
0
Hi guys, recently I upgraded my PC to i5 11400, AsRock B560 Pro 4 and 16GB of 3200ram from hyperx.
First thing I did was turning on the XMP.
I built it yesterday, everything was fine, I was playing games, etc no problem whatsoever.
Today I turned on one of the game I was playing yesterday and the PC shut itself down after 2 or 3 minutes, when trying to turn it on it would light up red CPU & DRAM light, fans and RGB will work but it seems like its not going to POST.
What I tried is:
  • Clearing CMOS
  • Running PC without GPU, HDD, SSD
  • Trying 1 stick of ram on every slot
  • I checked PSU on other PC, it worked
  • I checked RAM on other PC, it worked
  • Dissasembled the PC twice
  • Pins on the motherboard are straight
  • Capacitors look good
  • Cried in a corner
I am running out of ideas, if anyone has any other idea of what I can do or check then please do help me.
 
Hi ptK47.

Upgrading means you kept some parts including your PSU.

A system shutting down like that will mostly be caused by a PSU, overheating or GPU issue.

What is your full system specs including PSU brand and model?

And what do you mean by "It seems like it's not going to POST?". Is it posting or not? It can't be a "maybe".
 

ptK47

Prominent
Dec 3, 2019
7
0
510
0
Hi ptK47.

Upgrading means you kept some parts including your PSU.

A system shutting down like that will mostly be caused by a PSU, overheating or GPU issue.

What is your full system specs including PSU brand and model?

And what do you mean by "It seems like it's not going to POST?". Is it posting or not? It can't be a "maybe".
Okay so when I turn the PC on, red lights turn on, rgb turns on, fans turn on and it just stays like that in an endless loop?
Monitor shows no signal on dedicated and/or integrated GPU.

CPU - i5 11400
Cooler - Fortis 3
MOBO - AsRock B560 Pro 4
RAM - Kingston HyperX Fury 2x8GB 3200MHZ
PSU - Chieftec ctg-750c - I hooked it up to another PC and it worked without a problem.
Case - BeQuiet 500DX
 

ASK THE COMMUNITY