Question RX 5500 XT Bricked!

chrispopp8

Reputable
Jun 2, 2017
9
0
4,510
0
Recently bought a VisionTek RX 5500 XT to use in my system I'm building with a MSI MPG Z490 gaming edge wifi.

While setting up the system, the card was giving an error 43. When I was trying to fix it, circuit breaker blew twice. Power supply is a brand new 850W Gold Focus.

Thinking the card was used for mining, I ran DDU and wiped out the BIOS. However, I can't find a bios from VisionTek and when I called them, they said they wouldn't give it out.

GPU-Z says it's a kurotoshikou rx 5500 xt 8 gb. Can't find a bios for that either. Tried using a different rom and bricked it.

When booting, system won't post with the RX 5500 XT installed. Tried to use ID-MultiMonitor but as long at the RX 5500 XT was installed, no post. Thought I could re-flash the bios to unbrick it but...

GPU has no dual bios, no bios switch. I have read that you can jump cmos pins to reset but I have no idea where the cmos is located.

Bought on eBay so doing an rma is out of the question.

Any help would be much appreciated.

Mahalo
 
The gpu bios reflash is not a big deal, you can follow my guide here. For finding the right BIOS, you need the exact chip version/revision and also the memory module make/model to match, not explicitly necessary to look for the same vendor. Check what memory ICs are on the card and try any from this list that has the same memory modules. This should make the card get detected.
Error 43 is a different story. While it might be software-related, it often is hardware. It might have got damaged during shipping or was broken to start with. I would use eBay to return it as DOA after talking to the seller.
 
Last edited:
Reactions: Krotow

ASK THE COMMUNITY

TRENDING THREADS