Question Ryzen 2200g boot issue

Sep 7, 2019
2
0
10
0
Motherboard: Gigabyte B350 Gaming 3 ATX


So recently I bought a 3200G for a low cost build but realized after 15 mins of trying to get it to boot that my bios version was updated to F31 and not the Ryzen 3000 supported F40 that I needed so returned it and got a 2200G instead but the same problem occurred . The VGA led indicator becomes static red , same thing that happened with the 3200G but this time I couldn’t find any reason for it not to work. For this board the 2200G has been supported since the F10 Bios , I’ve tried different ram sticks , different ram dimms , triple checked all power inputs to the board , made sure the orientation of the CPU was correct, used a dedicated GPU for video output , tried the GPU in different slots , swapped the PSU and cleared the CMOS . Still! the same outcome ,the VGA led is static red. I’m not 100% that it’s not the motherboard but it booted with a 5 1600 previously . I don’t think that this has any affect in the boot issue but it’s on a test bench and not in a case so there no headers plugged in besides the Power Switch.
What else can I do?
 

ASK THE COMMUNITY

TRENDING THREADS