Question second monitor 'no signal detected'

Jun 29, 2019
17
0
10
0
I built a new pc with my old graphics card and it had a problem where i had to restart my pc everytime i wanted my second monitor to turn on.
Now that it's in my new pc only my main monitor can turn on and my second monitor is saying 'no signal detected!'.
ive tried many basic things already, such as, checking if its pluggedin properly, faulty cable, win+p to extend monitor, detect monitor in display settings and nvidia, updating gpu drivers, roll back drivers; none of them worked for me.
sometimes the second monitor would turn on if i unplug my main monitor, but the second monitor just stays at a black screen until i replug my main monitor then y second monitor returns to being 'no signal detected'.
PC specs:
Cpu = amd ryzen 5 2600x
ram = hyper x 8gb 2666hz
gpu = nvidia gtx 1070 8gb
m/b = b450 pro4
psu = 750w
os = windows 10 home 64bit
 
Have you tried to run the secondary monitor alone (without the primary)? It sounded like it still doesn't have a display. What inputs are available for it?

Might be worthwhile at this rate to know the monitor models we're dealing with.
 
Jun 29, 2019
17
0
10
0
Have you tried to run the secondary monitor alone (without the primary)? It sounded like it still doesn't have a display. What inputs are available for it?

Might be worthwhile at this rate to know the monitor models we're dealing with.
yes i have, all it does is give me a black screen on it and nothing i can do or press.
the two monitors i have are
AOC C27G1 FHD 144Hz Freesync Curved 27in Monitor
and
BenQ ZOWIE RL2755HM 27" Full HD TN Gaming Monitor
 
Which is the secondary monitor which keeps giving you the black screen?

So far it seems many things have been tried (with little success), so we're trying to see what might have been missed. We know secondary monitor keeps going to black screen, but using which input? I assume you've tried another input for it, but confirmation either way would make things clearer.

Some monitors allow for choosing an input: have you tried seeing if the monitor needs to be 'retuned' or set to it?
 
Jun 29, 2019
17
0
10
0
Which is the secondary monitor which keeps giving you the black screen?

So far it seems many things have been tried (with little success), so we're trying to see what might have been missed. We know secondary monitor keeps going to black screen, but using which input? I assume you've tried another input for it, but confirmation either way would make things clearer.

Some monitors allow for choosing an input: have you tried seeing if the monitor needs to be 'retuned' or set to it?
the benq is giving me the black screen which is using the dvi input
 
Jun 29, 2019
17
0
10
0
Have you tried the DVI port of the AOC? Would want to rule out either the cable or the DVI port of the graphics card being an issue.
the aoc has no dvi port,
though i just tried a hdmi cable on my aoc and the dp on another 144hz monitor and the aoc is still kept main and for a while nvidia control panel recognozed the second monitor but on the monitor itself it said there was no signal
 
Jun 29, 2019
17
0
10
0
okay right now im using a dp on my aoc which is turned on and working and i plugged another dp into another 144hz and its detected but the screen is black and on the monitor is says there is no signal
 
Misread the spec of the AOC.

So... a different monitor (a third?) using Displayport is detected but a black screen. Something strange going on. (Starting to think we'll need to make a table or something to keep track of combinations already tried....)
 
Jun 29, 2019
17
0
10
0
Misread the spec of the AOC.

So... a different monitor (a third?) using Displayport is detected but a black screen. Something strange going on. (Starting to think we'll need to make a table or something to keep track of combinations already tried....)
so i got home and turned on my pc again (at this time i had all 3 monitors hooked up, aoc with dp, benq with dvi and the third with another dp), all were detected but this time aoc AND benq was on, the third monitor wasnt.
i was playing on it for quite a bit and turned it off and turned it back on only for it to return back to its original state...
 
Jun 29, 2019
17
0
10
0
basically first monitor works, second monitor doesn't but when i connect a third monitor as a test, it is detected but the screen doesnt turn on, yesterday the second monitor was working but when i turned off my pc it would go back to saying 'no signal detected', i would have to turn off my pc and turn it back on to get the second monitor on but it's not working anymore.
This is all too confusing and i have no idea what is going on. iv'e tried many fixes already:checking if its pluggedin properly, faulty cable, win+p to extend monitor, detect monitor in display settings and nvidia, updating gpu drivers, roll back drivers, starting in safe mode, turning off fast boot; none of them worked for me.
PC specs:
Cpu = amd ryzen 5 2600x
ram = hyper x 8gb 2666hz
gpu = nvidia gtx 1070 8gb
m/b = b450 pro4
psu = 750w
os = windows 10 home 64bit
 

ASK THE COMMUNITY

TRENDING THREADS