Question Secure boot problem

adicretzu

Commendable
Apr 8, 2019
48
4
1,545
1
Hello. I have a Gygabyte B450m Gaming rev. 1 (motherboard), with a Ryzen 5 3600X. I want to disable Secure boot in BIOS for using some programs that doesn't wok with secure boot active. If i do that my windows is not booting, pc goes again in BIOS and all my HDD units from boot section disappears. How to disable the secure boot and be able to run my windows? This is my BIG question. I am trying for 2 days and cant find anyhthing on google to help me. Sorry for bad english (is not my native language). The wierd thing is that worked 2 or 3 months ago, and now is not working.
 

adicretzu

Commendable
Apr 8, 2019
48
4
1,545
1
Fail version with CSM disabled and secure boot disabled, if i dont disable CSM i can t reach the secure boot option to disable it, because will not apear



Working version with csm support enabled and secure boot disabled.

 
I think, you're misunderstanding things here.
If your system is installed in legacy mode, then secure boot is not available. Therefore you can't disable it. Secure boot is available in UEFI mode only.

If you're disabling CSM, this means you're turning off legacy boot. Only UEFI mode remains enabled.
Again - if system is installed in legacy mode and you just turned off legacy boot, then you can't boot the system anymore. This should be obvious.

Can you show screenshot from Disk Management? (just to verify your OS is indeed installed in legacy mode)
 

ASK THE COMMUNITY