Sound coming from speakers instead of headphones

whisperkill

Distinguished
May 11, 2011
5
0
18,510
0
Hey so I have a new computer that I built and I bought Razer Megalodons to use. Unfortunately when I plug them in the sound still comes out of my speakers. The microphone seems to be working fine.

If anyone knows anything that could help me it would be greatly appreciated.
 

mintrepublic

Distinguished
May 20, 2011
3
0
18,510
0
I'll assume you're running Windows 7. In Control Panel, go to Hardware and Sound -> Manage Audio Devices. Your speakers are probably set as the default (green check). Click on your new device and click "Set Default". I don't really know what Razer Megalodons are, but if they're USB-based, you'll probably also have to install a driver, which would come with it.
 

whisperkill

Distinguished
May 11, 2011
5
0
18,510
0
Ok. Well for some reason my speakers are listed as headphones and my headphones are named speakers. Even so that didn't work.

The only thing that changed is that when I set speakers (really the headset) to default the audio on some things does not work at all and the audio which does work comes out of my real speakers.
 

soulreaper666

Distinguished
Aug 11, 2010
34
0
18,540
1
If you've tried all the settings in control panel -> sound & your sound control panel it may be that something needs an update..

Man i luv the razer site..
You could try the updated firmware, maybe this has fixed this problem;
http://www.razersupport.com/index.php?_m=downloads&_a=view&parentcategoryid=37&pcid=78&nav=0,78

Things you could upgrade/update also ;
your sound card/onboard sound driver/software
make sure your OS has the latest service pack, for XP sp3 and 7 sp1

Use a program like driver sweeper to clean any drivers you're updating.. goodluck
 

Dustboonies

Honorable
Apr 30, 2013
25
0
10,530
0
I have the same problem, instead of messing with the drivers, I just disable the speakers (by going to the playback devices menu) and all of the sound goes through the headphones. Also, since I'm on a laptop, my laptop mic would take priority over my mic on my turtle beaches as well so I disabled my laptop mic and it worked perfectly.
Hope this helps :)
 

Similar threads


ASK THE COMMUNITY