[SOLVED] speaker volume fluctuating using toslink on new pc build

alanjames82

Honorable
Apr 30, 2016
44
3
10,545
1
i7 12700k
MSI mag tomahawk wifi z690
gigabyte gaming oc 3080 12gb
32gb corsair vengeance @3600Mhz
samsung 980 pro 2tb m.2
seasonic focus gx-850 psu
windows 11, latest build

so i just built this pc and used the same speakers i had from my previous machine (Ruark MR1 Mk2) via optical connection. The sound plays at normal volume then dips to near quiet, briefly and then returns to normal volume, every 10 seconds or so
ive disabled windows lowering volume if it detects communications activity; messed around with the sample rates the speakers use; updated the driver for high definition audio in device manager; installed the latest Realtek high def audio drivers. but nothing changes.
The optical cable appears to transmit a steady light, with no breaks
i think i had this problem with these speakers when i first got my previous pc but i dont remember how i solved it.
any help appreciated
 

dwd999

Honorable
i7 12700k
MSI mag tomahawk wifi z690
gigabyte gaming oc 3080 12gb
32gb corsair vengeance @3600Mhz
samsung 980 pro 2tb m.2
seasonic focus gx-850 psu
windows 11, latest build

so i just built this pc and used the same speakers i had from my previous machine (Ruark MR1 Mk2) via optical connection. The sound plays at normal volume then dips to near quiet, briefly and then returns to normal volume, every 10 seconds or so
ive disabled windows lowering volume if it detects communications activity; messed around with the sample rates the speakers use; updated the driver for high definition audio in device manager; installed the latest Realtek high def audio drivers. but nothing changes.
The optical cable appears to transmit a steady light, with no breaks
i think i had this problem with these speakers when i first got my previous pc but i dont remember how i solved it.
any help appreciated
You could try opening the Device Manager and checking the Properties for all of your sound device entries. If there's a Power Management tab for the device, you want to make sure that the box "Allow the computer to turn off this device to save power" is UNchecked.
 

alanjames82

Honorable
Apr 30, 2016
44
3
10,545
1
You could try opening the Device Manager and checking the Properties for all of your sound device entries. If there's a Power Management tab for the device, you want to make sure that the box "Allow the computer to turn off this device to save power" is UNchecked.
hi, unfortunately there is no power management tab for the device
 

dwd999

Honorable
hi, unfortunately there is no power management tab for the device
Since the specs for your motherboard indicate an ALC4080 audio chip, which is usb audio, you actually do not need any drivers for audio output. The whole point of ALC4080 is that windows provides the audio output as part of the usb system. So you could try uninstalling all of your audio drivers and see if that helps since they never should have been installed in the first place. In an ALC4080 system audio drivers are only needed to provide input functions. Or this could be another flaw in the ALC4080 audio chip. Realtek has already release 2 firmware patches for this chip so it could still be defective. Perhaps you could try your speakers in the bluetooth mode to see if that helps. Or you could temporarily disable bluetooth on your motherboard to see if that helps.
 

alanjames82

Honorable
Apr 30, 2016
44
3
10,545
1
Since the specs for your motherboard indicate an ALC4080 audio chip, which is usb audio, you actually do not need any drivers for audio output. The whole point of ALC4080 is that windows provides the audio output as part of the usb system. So you could try uninstalling all of your audio drivers and see if that helps since they never should have been installed in the first place. In an ALC4080 system audio drivers are only needed to provide input functions. Or this could be another flaw in the ALC4080 audio chip. Realtek has already release 2 firmware patches for this chip so it could still be defective. Perhaps you could try your speakers in the bluetooth mode to see if that helps. Or you could temporarily disable bluetooth on your motherboard to see if that helps.
thanks again for the response. i tried uninstalling all audio drivers but this did not help. neither did turning off bluetooth. although the speakers work flawlessly using bluetooth and audio from the pc
 

Paperdoc

Polypheme
Ambassador
Another thought - mo idea if needed here. Some systems use an Automaitc Gain Control system to boost very quiet audio pickup. These can cause paeriodic changes in loudness of the sounds on speakers if the ambient sounds being amplified change, especially if things often are quiet.
 
Last edited:

ASK THE COMMUNITY