[SOLVED] SSD not booting. Recognized as a SATA PM

Dec 27, 2018
1
0
10
0
Today as I was using my pc like I normally do, everything just froze. I restarted, and windows prompted me with a repair screen, saying that an important boot device isn't connected (I have windows 10 installed on the SSD). In BIOS it shows as a "SATA PM" and no longer says the brand of the SSD (in this case kingston). It still says it's 240GB but refuses to boot from it. I've tried different ports, different cables, but nothing worked. My hard drive works and is recognized without problem. I don't have another computer to test on but I feel like the SSD just failed. Any help?
 
Using an OS that is a carryover from a different build may not work if the systems hardware isn't similar.

Try clearing the CMOS and doing a clean install after deleting all existing partitions on the drive. You have an opportunity to do that at the beginning of the Windows 10 installation.
 
Boot from the original installation DVD (or the recovery USB)
At the Welcome screen, click Repair your computer
Choose Troubleshoot
Choose Command Prompt
When the Command Prompt loads, type the following commands:

bootrec /FixMbr
bootrec /FixBoot
bootrec /ScanOs
bootrec /RebuildBcd
 

ASK THE COMMUNITY

TRENDING THREADS