Question Strange M.2 issue - B450/Ryzen 5700G

Mar 1, 2022
1
0
10
0
Hi,

I’m troubleshooting one of the stranger issues I’ve ever come across…

I have an Asus Prime B450M-A II, a Ryzen 5700x and an Inland 1TB pci-e M.2 drive from microcenter.

If I use the integrated graphics, and install windows, the machine crashes when windows updates the display driver. and then a boot/Recovery loop happens. I tried the most recent beta bios for the board and the last full release version. Is the board incapable of using an M.2 and integrated graphics?

If I install a graphics card the system works just fine.

Conversely if I load windows onto a SATA SSD and use integrated graphics it works just fine.

ested the CPU and SSD in a Gigabyte X570 Gaming X board and it worked just fine.

the drive passes the extended self test in the bios, the ram is known good and works in other systems.

anyone have any advice? I ordered another M.2 drive to try, as I like to use this system for a media center PC in the living room.
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
55,560
4,337
160,590
10,083
Edit: do you have a 5700G or a 5700X?
your topic says one but text says another.

I had originally answered topic but then read body and saw X and changed it to below...


A 5700X doesn't have integrated graphics? so no wonder you have a crash without a GPU

Curious how it works on the X570 as igpu is in the CPU, not on the motherboard.

motherbaords have DP & HDMI to support APU, Ryzen X series don't have IGPU cores.

not to be confused with this which is a GPU - https://www.amd.com/en/products/graphics/amd-radeon-rx-5700-xt



But if you do have a 5700G it makes more sense.

is this win 10 or 11? is it up to date?

Did the 5700G Igpu work on the X570?

why not download the VGA drivers from Asus instead of letting windows get them?

or from AMD - https://www.amd.com/en/support/apu/amd-ryzen-processors/amd-ryzen-7-5000-g-series-desktop-processors-radeon-graphics/amd
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS