Question System Agent Configuration Option missing

Dec 8, 2019
20
0
10
0
Hello,

I am trying to use my GPU for my Main monitor and my CPU for my second monitor. Unfortunately, while following the steps to enable this I could not find the "System Agent Configuration" option. I have a "ROG Strix GL12CP" motherboard.

All help will be appreciated.

Note: I have noticed that a lot of people ask why I am trying to do this because it seems pointless but it will fix a bug I am having with my monitors. The bug is that I have different refresh rates for the monitors and that makes one of my monitors choppy. If you can help solve this problem with another solution I can try that out so I don't have to mess about in my BIOS.
 
Last edited:

Starcruiser

Honorable
May 18, 2013
897
28
11,390
209
First off, what cpu are you using? It would be easier if it was an apu with a built in graphics unit.

I had the issue with different refresh rates before, one was gsync 75hz over displayport and the other was plain 60hz over hdmi.
Disabling windows game mode is a good starting point for fixing it. MS loves to make unnecessary features into bugs.
 
Dec 8, 2019
20
0
10
0
Hey Starcruiser,

The cpu I am using is an Intel(R) Core(TM) i7-8700 @ 3.20GHz 3.19GHz.

I have already disabled windows game mode but there was no affect.
 

Starcruiser

Honorable
May 18, 2013
897
28
11,390
209
Hey Starcruiser,

The cpu I am using is an Intel(R) Core(TM) i7-8700 @ 3.20GHz 3.19GHz.

I have already disabled windows game mode but there was no affect.
Well using the integrated GPU is out because the i7 doesn't have one.

The problem you described is a very common one that is Windows 10 related, present since 1809 update. Here's a couple more things to try:
Go to your nvidia control panel and click on adjust desktop size and resolution. Set both your monitors to "Perform Scaling on" to your GPU and not the display which is the default.
Go to your settings in chrome and click on advanced options at the bottom and [disable hardware acceleration]
Set the refresh rate on your 144Hz monitor to 120Hz, or a 75Hz monitor to 60Hz. (it scales better with multiples of 60)
 
Dec 8, 2019
20
0
10
0
Well using the integrated GPU is out because the i7 doesn't have one.

The problem you described is a very common one that is Windows 10 related, present since 1809 update. Here's a couple more things to try:
Go to your nvidia control panel and click on adjust desktop size and resolution. Set both your monitors to "Perform Scaling on" to your GPU and not the display which is the default.
Go to your settings in chrome and click on advanced options at the bottom and [disable hardware acceleration]
Set the refresh rate on your 144Hz monitor to 120Hz, or a 75Hz monitor to 60Hz. (it scales better with multiples of 60)
Hey! Thanks for the reply.

I have done all these steps, but unfortunately there is still no change.

Is there anything else I can try?
 
Dec 8, 2019
20
0
10
0
This comes back to my first post. As I previously stated, the “System Agent Configuration" option is missing and that is basically why I need help.
 
Last edited:

Starcruiser

Honorable
May 18, 2013
897
28
11,390
209
The only remaining thing I can think of is that asus decided to remove or replace the system agent in their pre-built system. I'll send a support request to asus and see what they say. In the meantime, get some screenshots of what bios settings you have available in case they renamed the option.
 
Dec 8, 2019
20
0
10
0
The only remaining thing I can think of is that asus decided to remove or replace the system agent in their pre-built system. I'll send a support request to asus and see what they say. In the meantime, get some screenshots of what bios settings you have available in case they renamed the option.
Okay, I will get you some screenshots. I have seen some other people say that it “magically reappeared” but that wasn’t very helpful.

EZ Mode: https://cdn.discordapp.com/attachments/323600883202129920/659917982780227595/image2.jpg

Advanced Mode:
https://cdn.discordapp.com/attachments/323600883202129920/659917982780227594/image1.jpg

Advanced Tab:
https://cdn.discordapp.com/attachments/323600883202129920/659917982272585748/image0.jpg
 

Starcruiser

Honorable
May 18, 2013
897
28
11,390
209
Crap, I was wondering why you weren't replying lol. I forgot to quote you
That happens a lot really. I try to go back and look at the threads I post in but there's so many...

You could start disabling onboard devices that you don't need/use like the onboard serial port. You might trigger the magic that got that one person's menu to appear. (by allowing additional resources to be allocated elsewhere)
 
Dec 8, 2019
20
0
10
0
That happens a lot really. I try to go back and look at the threads I post in but there's so many...

You could start disabling onboard devices that you don't need/use like the onboard serial port. You might trigger the magic that got that one person's menu to appear. (by allowing additional resources to be allocated elsewhere)
That didn't really help. Is there anything else I could try?
 

Starcruiser

Honorable
May 18, 2013
897
28
11,390
209
The only other thing I can think of is remove your gpu and plug the monitor into the motherboard, then go into bios and make adjustments under the system agent menu. Hopefully the menu sticks around after you put the gpu back since settings were changed in it.

If it still doesn't work though, I would only guess that you got a bad chip that doesn't have a working gpu.
 
Dec 8, 2019
20
0
10
0
New information has come up and it looks l
The only other thing I can think of is remove your gpu and plug the monitor into the motherboard, then go into bios and make adjustments under the system agent menu. Hopefully the menu sticks around after you put the gpu back since settings were changed in it.

If it still doesn't work though, I would only guess that you got a bad chip that doesn't have a working gpu.
got some help, looks like my gl12 chip blocks onboard graphics and gpu together. thanks for trying to hepk tho
 

ASK THE COMMUNITY

TRENDING THREADS