Question System is assigning half the ram as hardware reserved

Aug 17, 2019
2
0
10
0
Hello there, I'm having this issue and after searching for the last couple of days i have yet to find a solution, so here goes

I recently bought a kit of Corsair Dominator Platinum 4x16 64gb 3200 MHz ram and for the life of me can't make the whole 64gb available as half is being hardware reserved according to task manager and windows.

This are the systems specs
OS: Windows 10 x64bit Home
Mobo: Gigabyte AX370 Gaming Rev1
CPU: Ryzen 7 1800x @ 3.60GHz
RAM: Corsair Dominator Platinum 4x16 64gb 3200MHZ
previously I had 2 2x8 Vengeance LPX with different frequencies for a total of 32gb running without a problem
GPU: GTX 1070 8Gb
Storage: 1 500gb WD Blue 3D NAND SSD M.2, 1 250gb WD Blue SATA SSD (Where the OS is installed), 1 2tb Toshiba HDD

I've tried the following,

-Uncheck maximum memory option in msconfig
-Updated the Chipset drivers to the latest version
-Used the registry editor to change values as per some suggestions on other threads
-Have updated BIOS
-I have tested individual sticks and in pairs in different slot positions and they work so I'm pretty sure its not a stick issue
-I've reseated the CPU and made sure the cooling block is properly mounted
-I've done a reset of the CMOS
-Tried different different setups with other ram sticks I have including OEM Dell sticks, same issue half gets hardware reserved
-Physically inspected the motherboard to see if there is any damage
-Turned on XMP in BIOS settings
-Messed around with different voltages for the ram

Currently trying,
-I'm making a bootable Ubuntu drive to see if there's a possibility this is a windows issue

So far there has been a few things that stand out, and some that are just weird to me
-Speccy shows all 64gb but of an unknown type and running at 1066 MHZ with 32gb total of physical and 55gb total of virtual
-Speccy also shows that the video card has a total of 4gb memory but I think this is just a bug
-CPU-z shows all 64gb running at 1066MHZ
- Task manager shows 32gb of ram available running at 2133 MHZ
-Task Manager also shows 24gb of graphics memory 8gb from the video card and 16 from shared memory.
-Display properties says that total graphics available is 24gb again with 8gb dedicated and 16gb shared, this leads me to believe that 1 stick is being assigned to graphics and as far as I can tell I can't change this in the BIOS as my CPU does not have an integrated GPU.
-I updated the Bios to the latest version but for some reason after a few restarts and parameter changes it reverts to a previous version, I have no idea why this happens and I've updated a couple of times now
-Memtest only detects 32gb of ram when running the tests

I'm stumped and have no idea what the issue is, the only thing I can think of now is that it is a compatibility issue somehow, (the Mobo has support for 64gb even though it says the speed varies depending on CPU and all info I've read says that my setup is compatible)
This is a setup that I'm gradually gonna upgrade and I started with the ram because its what I need the most at this time.

Either way any help would be greatly appreciated.
 
Aug 17, 2019
2
0
10
0
Memory Configurations
https://en.wikichip.org/wiki/amd/ryzen_7/1800x

See chart on above page for the officially supported memory configurations. Notice how only populating two of four memory slots allow the higher frequency speeds. When populating four of four memory slots the supported memory speed is much lower.
Thanks for the info, I figured as much that the speed would be lowered when having all four, the issue in itself is not the speed but the capacity, I use this system for heavy rendering visualization and the software engines are CPU based so eventually they "fill up" the 32gb and start writing on disk which then causes the rendering to slow down, so I figured the first upgrade would be RAM so I could address this issue before getting a new more capable CPU.
 

ASK THE COMMUNITY

TRENDING THREADS