Question "System" process shows high CPU usage when joining a voice chat in Discord ?

jorokitaeca

Commendable
Aug 21, 2019
19
0
1,510
0
Upon joining a voice chat in discord a process called "system" gets up to 20% cpu usage. It only happens when I join a voice chat using discord by itself doesnt cause this problem. My pc specs are
Ryzen 5 3500
GTX 1070
16GB 3200mhz
This has been happening as of yesterday out of nowhere
 

jorokitaeca

Commendable
Aug 21, 2019
19
0
1,510
0

Colif

Win 10 Master
Moderator
is microphone USB or other? Does it have its own software?

just wondering if its a driver issue for the microphone instead of Discord to blame.

app auto updates so no point trying to update it to fix it.

i wonder if you got any windows updates that could be cause. Worth looking since it just started.
 

jorokitaeca

Commendable
Aug 21, 2019
19
0
1,510
0
is microphone USB or other? Does it have its own software?

just wondering if its a driver issue for the microphone instead of Discord to blame.

app auto updates so no point trying to update it to fix it.

i wonder if you got any windows updates that could be cause. Worth looking since it just started.
I think the cause is from the realtek audio drivers I have. They're up to date but when I uninstall them and join a vc I don't have this problem. But that way I won't have audio of course . Are realtek drivers the only audio drivers out there? Literally can't find anything else to try
 

Colif

Win 10 Master
Moderator
realtek? probably. 90% of motherboards have realtek audio so there is that.

You could, after uninstalling them, run windows update as it will find older realtek drivers and maybe they will work better

unless it was a windows update of the audio drivers that caused it, why i asked about recent updates.
 

jorokitaeca

Commendable
Aug 21, 2019
19
0
1,510
0
realtek? probably. 90% of motherboards have realtek audio so there is that.

You could, after uninstalling them, run windows update as it will find older realtek drivers and maybe they will work better

unless it was a windows update of the audio drivers that caused it, why i asked about recent updates.
Long story short. I installed older realtek drivers right. Plugging in my USB headphones that partially don't work fix this problem, but if I plug in my two jack headphones into my front or back panel the system process once again starts going up to 20% cpu usage.... this is the weirdest thing ever
 

Colif

Win 10 Master
Moderator
right click start button
choose powershell (admin)
type SFC /scannow and press enter
once its completed, copy/paste this command into same window:
Repair-WindowsImage -Online -RestoreHealth
and press enter


SFC fixes system files, second command cleans image files, re run SFC if it failed to fix all files and restart PC

another thing to try:
Try a clean boot and see if it changes anything - make sure to read instructions and make sure NOT to disable any microsoft services or windows won't load right - https://support.microsoft.com/en-au/help/929135/how-to-perform-a-clean-boot-in-windows

if clean boot fixes it, it shows its likely a startup program. You should, over a number of startups. restart the programs you stopped to isolate the one that is to blame.
 

jorokitaeca

Commendable
Aug 21, 2019
19
0
1,510
0
right click start button
choose powershell (admin)
type SFC /scannow and press enter
once its completed, copy/paste this command into same window:
Repair-WindowsImage -Online -RestoreHealth
and press enter


SFC fixes system files, second command cleans image files, re run SFC if it failed to fix all files and restart PC

another thing to try:
Try a clean boot and see if it changes anything - make sure to read instructions and make sure NOT to disable any microsoft services or windows won't load right - https://support.microsoft.com/en-au/help/929135/how-to-perform-a-clean-boot-in-windows

if clean boot fixes it, it shows its likely a startup program. You should, over a number of startups. restart the programs you stopped to isolate the one that is to blame.
View: https://imgur.com/a/fuZCqR7

did everything you said, nothing changed
 

ASK THE COMMUNITY

TRENDING THREADS