Touchpad help


Aug 30, 2007
According to my laptop I have a packard bell Easynote sw51-120
After losing the harddrive I did a fresh install on a new drive.

Went on PBs website and downloaded all the drivers for my model.
Only trouble is PBs website is wrong.

Says I have a ralink wireless when in fact its an atheros.
I've sorted that.

But before the crash I had managed to disable my touchpad because I use a small mouse and mini receiver.
I've now downloaded 4 different synaptics drivers (even latest from synaptics) and I cant get the ah heck to be recognised.
So at the moment I use my mouse but the touchpad still works and gets in the way when my hand brushes against it.
I cant disable as if i try to install the software and drivers It says another is already installed.
I've tried deleteing all mouse drivers and it still works!

Can't ask on PB forum as they havent worked in months.

Also tried driver detective which proclaimed that I had an Easynote R4.

packrd bell sw51-120
vista sp2 (kosher)
3 gig ram
150 gig HD
nvidea gforce go6100 (crap)