Question upgrading cpu end up my computer boot without any display

Apr 4, 2021
3
0
10
0
hi everyone. I'm new here.. this morning I decided to upgrade my cpu from Pentium G2010 to Core i5 2500... The i5 is used unit and I bought it online.. They tested before shipped to me and everything is good.. back to my issue, I followed the instructions, all is ok except for stock Intel heatsink, which I broke 3 of the 4 push pin.. But the one left holds up quite nicely to the board.. So I decided to continue with it.. My computer boot up, for at least a second then restart before boot up normally.. No beep, no any bad burning smell whatever,. But no display, it just black.. I try to switch in between my gpu and igpu, still no luck.. Try many other things, reseat the ram, clear cmos jumper, cmos battery still no luck.. Please help me out.. Thanks in advance. 😬

MY SPEC

CPU: Intel Core i5 2500 3.3Ghz
GPU: Asus GT630 2GB
HDD: 500GB Seagate/500GB Hitachi
MOTHERBOARD: Asus P8h61-M Plus v3
RAM: 4GB Kingston 1333Mhz +2GB Kingston 1333Mhz
PSU: 500w

NOTE : all of my spec are the same as previously with Pentium G2010, except for the i5 processor
 
Last edited:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

3 out of 4? That would mean you're in need of a new (aftermarket)cooler for that processor. What is the make and model of your PSU and it's age? You will also need to see what BIOS version you're currently on for your motherboard. Work with only one stick of ram, you're making things worse by mixing and matching sticks of ram. You should look into a dual channel ram kit as well.
 
Apr 4, 2021
3
0
10
0
Welcome to the forums, newcomer!

3 out of 4? That would mean you're in need of a new (aftermarket)cooler for that processor. What is the make and model of your PSU and it's age? You will also need to see what BIOS version you're currently on for your motherboard. Work with only one stick of ram, you're making things worse by mixing and matching sticks of ram. You should look into a dual channel ram kit as well.
Yes, I already ordered cooler master branded yesterday.. Now waiting for it to come.. By the way my psu is 500w.. I don't know what brand it is because this pc is Nec branded and since 2013 I keep upgrading hardware like mobo, ram, etc but I never upgrade the psu. You can refer to the link attached for my psu details
https://ibb.co/235F8Vv
 
Apr 4, 2021
3
0
10
0
Hi again everyone, a little update after more than 10 days, my pc booted up perfectly fine after I replaced the cpu fan with Cooler Master i30, also i replaced the ram with Kingston HyperX 8GB 1866mhz x2. I don't know how to closed this thread, so I hope Moderator can help me with this.. Thanks everyone
 

ASK THE COMMUNITY

TRENDING THREADS