Usable RAM


Dec 11, 2011
I have a dell precision 690 and have 8gb of ram . i also have a 64bit windows 7 professional installed but when i go into system it says 8gb of ram detected but only 4.00 useable . i went into the bios to see if i could enalble memmory remapping as i saw that was a common fix but when i went in there was no option available does anyone know a fix for this problem or experiened similar problems ?


Click Start and type msconfig in the search files and folders field. Click Boot then advanced options. Make sure Maximum Memory is deselected. If it isn't it will probably say 4 GB Max. Deselect then reboot. See how that goes.


Mar 27, 2013

I have BIOS A08, 8 x 1GB RAM installed on the 690's risers, Win 7 Pro 64-bit. BIOS shows all 8 sticks but reports 4 GB; Win 7 reports 8 GB, 4 GB useable. Sound familiar? This is essentially the same dilemma reported by many, MANY users in many support sites (including Dell's). Yet I have seen neither a valid explanation nor a solution that works..

I've tried the above msconfig routine but …nada. Same for the many ideas ive found and tried. I know that 690s are no longer under Warranty (or even in production), but there are a lot of customers who bought their machines on the promise of their being able to address up to 64 GB (in a 64 bit OS) and are now out on a limb and abandoned. Come on Dell and Microsoft, throw us a line, PLEASE!