[SOLVED] USB 3.0 devices and USB 3.0 front header not working

Dec 18, 2019

Have just built my first PC, all went well until i plugged in a USB flash drive. I have an up to date BIOS and have downloaded all the available drivers from AMD and ASUS mobo drivers to no avail.

Firstly, the front USB 3.0 header does not work for any type of USB device, seems completely dead. I am using my old case so i know the USB header worked with my last mobo.

Secondly, the rear USB slots work for my keyboard and mouse, USB 2.0 flash drives, BUT will not recognise anywhere a USB 3.0 flash drive.

Strangely, it registered my 3.0 flash drive in a rear port one time and showed up as expected on 'This PC' but i cannot seem to repeat it. It just does not show under 'This PC' or in device manager.

Can someone please help, have searched the internet for hours with no results.

Thanks in advance

CPU=AMD ryzen 5 2600x
MoBo= ASUS prime B450M-A
RAM= 2x8gb Corsair vengence 3000mHz
NVMe= adata sx8200 pro 512GB
GPU=ASUS GEforce GT710 2GB

Windows 10 64x


I have 3 Dell desktops and 1 Dell laptop where the USB3 ports all work fine with the Public version of Windows 10 and the latest Insider builds, so I know it's supposed to work with both USB2 and USB3 devices. My suggestions would be to first double check your wiring, then if you don't find anything, contact Asus support.