Very low SATA HDD transfer speed

xj9a

Distinguished
Oct 17, 2011
6
0
18,510
0


Very slow, as you can see. I'm running Windows XP SP3. My motherboard is an ASUS K8S-MX which has 2 1.5 Gbps SATA ports. The drive is SATA 3 Gbps with a jumper placed to limit it to 1.5 Gbps. I don't know if that's actually necessary to get this drive to work with this motherboard because I've never tried it without the jumper. Another drive just like it (they were purchased together) in a different computer works as expected, and to my knowledge this drive had normal performance while it was in that computer as well.

I've tried to find out if this might be a problem with the board's SATA controller or if I need to install a driver for it, but I've been unable to find any information about my specific problem. Can anyone give me an idea of what's wrong and how to fix it?
 
The SATA 1.5 jumper won't be the issue here - SATA 1.5 is much faster than just a few MByte/sec.

Does Task Manager (Ctrl+Shift+Esc) show that your CPU is really busy while you're running the test? You may be in PIO mode, which bottlenecks IO by requiring the CPU to process every byte that's read or written instead of letting the device move it directly to or from memory on it's own (DMA mode).

This page has instructions on how to reset it back to DMA mode.
 

xj9a

Distinguished
Oct 17, 2011
6
0
18,510
0


It was maxing out the processor, but I couldn't find anything related to this drive in the hardware manager, until after I installed the driver from ASUS' site. Anyway, the driver got it working. Minimum rate is now 32 MB/s, maximum 58.

Thank you both for the help.
 

ASK THE COMMUNITY

TRENDING THREADS