Question Weird issue with new build. Can watch videos, etc, but can't download files.


Oct 31, 2013
Good Evening, I've got a doozy here that I can't seem to figure out. I was able to find another post that is almost exactly what I am experiencing, but the solution is not correct for what is happening here. Link below.

The Problem and Hardware:

I have a brand new PC using an AMD Ryzen 5 2600X and Gigabyte GA 320M motherboard. Originally, I tried to use a TP Link wireless dongle for network connection. However, I was unable to download files from the internet or update games. Basically, any type of file download will fail after a few seconds (It starts at normal speed, but quickly ticks down to 0Mbps before stalling out). Also, Discord will cut-out periodically and display the "red" status for server before going green again. No voice will go through while it is out, but there isn't any indication of a network issue while this is happening.

The weird part is that I can browse to YouTube and watch any video just fine, Facebook messenger will make calls just fine, and I can remote desktop to the PC using quick connect just fine. While logged in remotely, I can observe all these issues even though I am connected to the PC using the network connection.

I can play online games such as escape from Tarkov, but if the launcher needs to update it will fail.

Every other device in the house (another desktop, two laptops, Amazon fire, tablets, phones, etc) works just fine and has no issue with file downloads or Discord. The Router is a XR500 Nighthawk connected to netgear 8-port switch. The Nighthawk is set to use Pi-Hole for DNS and the internet connection is 100Mb symmetrical fiber.

Troubleshooting steps:

I have bypassed the Pi-hole both by setting a static IP/DNS on the PC and by changing the router configuration to use google's DNS. No change. I've used several different internal IPs and DNS servers as well.

Can ping with no noticeable latency to both hostnames and IP addresses while the issues are happening and while connected remotely from the other desktop.

Traceroute comes back normal for every site tested and match the other PCs.

I have ran a cable straight to the Router and tried a different wireless dongle. No change. The issues persist on every network interface.

I plan to replace the router with a spare to rule out router issues. I'm not hopeful for this change since nothing else is having the issue.

I ran a packet capture (wireshark) and didn't notice anything extremely out of the ordinary. There were quite a few "out of order" or "missed transmission" errors during the outage, but I've seen this on other devices and can't quite tell if it is a fluke.

Temporary Fix and oddities:

I was able to get the issues to go away temporarily by manually specifying a made-up MAC address, setting the IP address to static, and then switching back to DHCP. No idea why this works, but as soon as I plug-in the wireless dongle the issues come back and I have to re-accomplish this "fix".

The router was displaying two IP addresses for this new machine, which is what made me lean on it as a cause. Setting a new MAC will make the router think it's a new device and clear out anything it may be holding onto. However, the issues still come back if there is the slightest change in configuration. I don't have a practical way to have a cable ran to this PC.

I'm at the end of possibilities and I'm wondering if anyone else has seen anything similar and what the fix was. I'm leaning towards a hardware issue, but the fact that it is technically "working" makes me think otherwise. I'd also think the wireless adapter was faulty, but the issue is spread across both wireless and wired. The router having some sort of issue would make sense, but again there are no other devices on the network having this issue.

Thanks in advance!
So many things can affect this but it almost has to be some software or setting that is causing it.

Does something like speedtest work correctly. This is actually a file download and upload it just does not keep the file. What happens if you attempt to copy files between machines inside your house.

To rules out hardware issue you could boot a linux USB image. To a small extent you will be limited on what you can download because it will go to the USB stick, you want to avoid letting it touch your main OS disk.

The common suspected software tend to be to so called "gamer" network software. I would uninstall any software related to network QoS or favoring one form of traffic over another. Many times this stuff comes in the bundled crap with motherboards. Killer chipsets were the worst offenders but they have become much less popular so you don't see them as much.


Oct 31, 2013
Thank you for the reply! I'm pretty much with you on a software setting being the culprit.

Speedtest does not work (most of the time). It will work much like a file download where it shows successful ping, but the download will drop down to nothing in a few seconds. Sometimes, the speedtest will complete, but this is random and happens about once every 10 attempts. Sometimes a file download will succeed if it is a very small file and is tried a few times.

I have not tried a local file transfer, only local RDP. Will try this out tonight.

I can boot to a linux image after work and test that out. I'll let you know what the results are.

I'll also look for gamer software or anything that looks suspicious with the motherboard drivers. Mentioning QoS does give me a bit of a red flag since the router itself has priority traffic mode. I'll take a look at that as well, but I'm not sure why it would only cause an issue with this one PC.

At work now, but will give this a shot later.
control panel->Network and Internet->Network and Sharing Center

On the Access Type it will list your connections by your wifi name. It will be blue SSID Name. Click on it

This will bring up the Wi-Fi Status window which includes a bar graph for signal quality. Something tells me you have one or two bars lit.

Alternatively download WiFiAnlyzer by VREM Software (open source on android) and look at your signal strength that way. As you attempt to download a file, see what the signal strength does (when you are connected to same SSID)

I had a cheap horrid Linksys AC router that did the same thing. The Radios were burning out and this is what caused the issue.