[SOLVED] Weird pixels and games do not run after random crash

Jan 13, 2019
3
0
10
0
Hello! One day my PC crashed out of nowhere and when I turned it on again it did not start so I pressed the power button to turn it off.
After that, the monitor developed some weird pixels shown in the image and games which ran perfectly prior to the crash do not even open anymore.
I do not know what may be the cause of the issue, as the computer is quite old (2014)
Thanks!
http://
 

Pcnewby

Prominent
May 1, 2017
53
0
630
1


Probaly the gpu. I had an rx470 long time ago and random green pixels started appearing on my screen and my pc suddenly wouldn't boot. I brought it back to the store where I bought it and they tested it and they confirmed it was faulty thus instantly giving me a brand new one.

 
Jan 13, 2019
3
0
10
0

Wait, I just tried in a TV using a HDMI cable. When I used the HDMI slot of the GPU it happened the same, the weird pixels. But when I plugged the HDMI in the motherboard slot it didn't display anything.
Any thoughts?

 

Pcnewby

Prominent
May 1, 2017
53
0
630
1


Hmm that's weird. Try stress testing the gpu for a good time. See if any artifacts appear

 


looking at the artifact that appear on your screen the probability is very high the faulty one is the GPU not the monitor. also it is normal you can't display anything using the HDMI output from motherboard because usually the motherboard will automatically disable the IGP when discrete GPU being plug in into the system. to get any video output you still need to connect your monitor to your discrete GPU directly unless you make the changes in the BIOS to also enable IGP even when discrete GPU being plug in.
 

ASK THE COMMUNITY

TRENDING THREADS