Question whea_uncorrectable_error bsod infinite loop

Apr 1, 2021
2
0
10
0
This is rather lengthy so please bear with me. I have a computer I have put together a couple years ago which worked for about 1.5 years. One day I receive a "WHEA_UNCORRECTABLE_ERROR" that goes on infinite loop. Per usual to any error I get, I google search and arrive to drivers, windows update and whatever being the possible culprit to this particular error. Also, I read that it could be a possible hardware issue as well.

Specs to the computer in question are:
Windows 64bit Home Edition
CPU: Intel i5-7400
RAM: Corsair Vengeance DDR4 2400mhz 2x8GB
Motherboard: Gigabyte B250M-DS3H
PSU: Thermaltake 500W White
SSD: Samsung EVO 970 250GB M.2
TP-Link Wifi pci card
Some cheap Rosewill mid-tower case

Here's my troubleshooting nightmare. All changes I describe have no change on WHEA occurring or not.
This error would occur in the beginning, 1-5 minutes after logging into windows. So my time to look around before it would continually crash was short. Looking around at drivers or whatever I found nothing that stood out. Windows update did nothing to help, even removing previously installed updates did not help either. I started taking out hardware bit by bit, starting with the old e-machines wifi card(since replaced with TP Link wifi card) that was in there and it worked for about 20 minutes before the same error occurred again. Moving RAM position from 1,3 to 2,4 as the manual states it accepts both configurations. I even used each of the two sticks individually in all 4 spaces, no luck. I updated bios from Version F3 to present day F9. F3 was the out of the box version when built and I did not update before encountering this error. I decided to re-seat everything else, CPU, SSD, PSU cable connections across the board and disconnected all unneeded devices from the front panel i.e. usb 2.0, 3.0 etc. I have reinstalled Windows numerous time with 2 different flash drives with fresh installs of Windows Media Creation Tool. Installation would finish but then proceed to crash with the error as I get the to 'add keyboard layout'. Eventually the installations would not even complete, as at the very end it would prompt saying it could not complete windows installation. Safe mode to run sfc /scannow would fix an error but not solve issue. CHKDSK would find no errors. Memtest did not find anything. Also to mention, while in 'Safe Mode', windows is constantly prompting a crash to windows in the same manner that any program would stop working, but then I could continue to use it, but with it constantly freezing with a crash. However, no bsod while in safe mode but its still unstable and barely usable. When windows did not finish installation, I would think it was the SSD causing issues but just to be sure I proceed to use my own computer to start testing compatible hardware. Can use BIOS without crash even after letting it sit for an hour.

I use:
mobo: msi B450 tomahawk
cpu: ryzen 5 2600x
gpu: radeon rx590
ssd: samsung evo 960 500gb m.2
psu: thermaltake 750w bronze
ram: corsair vengeance 2x8gb 3000mhz

Using my computer I start individually placing hardware that would fit in mine, psu, ram, ssd. And eventually altogether. I was able to swiftly install windows and use it for up to 4 hours, having installed programs, some games or whatever to put the hardware to some demanding use. ZERO issues when in my B450 mobo. I even tested Escape from Tarkov as it demands a good bit of resources to try to rule out anything especially the PSU in this case. Everything is detected and reads specs as they should be. I even throw my hardware into the computer in question, PSU, SSD, RAM single or dual channel (clocked down to 2133mhz) and I still get the same bsod error. Also, when the SSD has new windows installed from my own computer and then put back in the original computer, it will proceed crash at the windows login screen like normal.

Since PSU, RAM, and SSD work in my own computer, I have not tried to get them replaced on Warranty. But I did request Warranty on Intel CPU and Gigabyte Mobo and they were replaced, new boxes and all. Nothing has yet to solve this WHEA bsod error.
The only farfetched, yet still possible thing I can think of is there's a short in the computer case (which only has the FPanel connected, Reset SW, Power SW and Power Led, no F_USB 2.0/3.0 or HD Audio). Which I have yet at this point to do a complete swap of computers into each other's cases. Otherwise maybe a short in the power cord, power strip, or something small unexpected.
Finally, I don't have voltage values at the ready but I did find that all voltage readouts are within acceptable range. and CPU temp sits at 32-37C as read in BIOS so there's no overheating. XMP is not enabled, OC is off. Changed UEFI to Legacy, Legacy to UEFI. Disabled all sorts of protection in the BIOS, Cleared CMOS to get older BIOS version back.

Something is wrong and I don't know what to do. Any thoughts?
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Thermaltake is the brand to the PSU while 750W or 500W is the wattage, it does not state the model of the unit(or the series from which it came from). How old is the unit in question(in your build)? So you went straight to BIOS version F9 instead of updating the BIOS gradually?

What OS version are you currently on? You might want to download all drivers relevant to the motherboard(that are the latest for your platform) and have them on a pen drive. On another pen drive use Windows Media Creation Tools to fabricate your bootable installer. Reinstall the OS, while disconnected from the www, once you've finished OS install, install all drivers in an elevated command, i.e, Right click installer>Run as Administrator, and see if the issue persists.
 
Apr 1, 2021
2
0
10
0
Apologies its been hard to keep track of absolutely everything, but I have done as you mentioned in command prompt as administrator to get latest drivers installed while disconnected from the internet. This didn't help either.

Thermaltake is the brand for both PSUs, 750W is for my own computer, 500W to the one with problems. I don't know the model# of either PSU nor the series off the top of my head. my 750w has been used for around 5 years whereas the 500w only has been used since the mid 2019. But both function as expected when placed into my own build under considerable load. I don't see issue with the PSU being that I can use either endlessly without problems in my computer.

Windows [Version 10.0.19042.867] is the readout for mine. The Media Creation tool gave the fresh install version 19042 as well. As to what version it was before bsod began, I have no clue but I did keep the system updated every month before bsod.
I have Win 10 64bit Home Edition on mine as well.
I have never had problems skipping versions of BIOS in the past just like this from F3 to F9 so I did not gradually upgrade versions. Also, the newly received motherboard came with F9 preinstalled. The problemed computer ran BIOS F3 all the way from freshly built to the moment it crashed so bringing it to F9 was just the first attempt to try to fix it. I only put this computer together Mid 2019 even though some parts have release dates back to 2016.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS