Question Why is my CPU Max clock speed all the time ?

Feb 21, 2020
13
0
10
0
I've tried lots of options such as battery options. I have reinstalled windows and all my games but the CPU still hits 100% when playing games. I went in the bios and did not understand much so I didn't touch anything.

- I checked for viruses with McAfee
 

Schlachtwolf

Upstanding
Jun 22, 2019
285
62
290
24
What CPU do you have and installed in what system, mobo,gpu, ram etc?
What game's do you play?
What is your monitor refresh rate and what FPS do you want to achieve.
Viruses will kill your PC or gather info quietly, more CPU eaters are Malware, run the free version from www.malwarebytes.com and see if it finds anything naughty.
 
Feb 21, 2020
13
0
10
0
Intel(R) Core(TM) i5-9400F CPU @ 2.90GHz
16.0 GB corsair Ram
NVIDIA GeForce GTX 1660 Ti
Two ultra-wide LG monitors at 60 FPS
normally achieve like 200 and now the game crashes every time I open it as the CPU maxes at 100%
 

Schlachtwolf

Upstanding
Jun 22, 2019
285
62
290
24
OK power is normally not an issue, have you checked your Task Manager to see what is using the CPU, I would run just wow with the TM on and see if it is really the game that is doing the harm. It is a good gaming CPU and should be able to handle wow easy enough....
 
Feb 21, 2020
13
0
10
0
I have and the task manager says that the game is extremely high power usage
even now when having two browsers open and the task manager open
chrome is using 5-15% of the CPU whereas it used to hit 5 as a max
 
Feb 21, 2020
13
0
10
0
DO NOT insult people trying to help you.
What kind of logic is that
Ive been playing games for a while now and this has never happened before
MOD EDIT: personal attack removed
 
Last edited by a moderator:

Schlachtwolf

Upstanding
Jun 22, 2019
285
62
290
24
Are you sure that ALL 6 cores are at 100% or just the primary core for wow?

WoW only needs 1 core to operate properly unless you've got some setting changed. Go into the task manager and under the "details" tab, find the WoW application, and then set affinity to either 1 or 2, depending on if you want 1 or 2 cores allocated to it. Or if you have hyperthreading, multiply those values by x2. So 2 cores is 1 core, and 4 cores is 2 cores.
 
Reactions: Roman Karimi
so the PC Automatically does it without telling you that its changed the bios.👏👏👏👏
i5-9400F base frequency is 2.90 GHz, turbo boost frequency is 4.10 GHz.

When cpu load requires it, it will automatically overclock up to 4.1Ghz. Those are default settings in BIOS.
That's, how it works.

Here - some links. Please educate yourself.
https://www.intel.com/content/www/us/en/architecture-and-technology/turbo-boost/turbo-boost-technology.html
https://ark.intel.com/content/www/us/en/ark/products/190883/intel-core-i5-9400f-processor-9m-cache-up-to-4-10-ghz.html
 

ASK THE COMMUNITY

TRENDING THREADS