[SOLVED] Why won't my Windows 10 PC go to sleep automatically?

Page 2 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.


If it's a USB fan, then you just need to figure out which USB controller it controls and in the device manager settings look at the power management tab for the specific USB hub or controller, and disable the setting that says "allow this device to wake the computer". It might take trial and error to figure out WHICH hub or controller that USB port is attached to in device manager.

Saga Lout

Olde English
I went through them all and none of them can wake the computer, the box is greyed out for every USB port.
And they're probably all ticked in the box above that; the one that says the device can turn itself off to save power.

I'm struggling to work out whether that may cancel the other setting out. Also, there's a lot of difference between "waking the computer" and "won't go to sleep automatically".

Have you checked the Networking settings to see if your PC can be wakened by another?


Apr 21, 2015
I'm going to mark an earlier post of yours as the solution because even though the USB fan causes variances on when the computer goes to sleep, that wasn't my original issue and it never keeps my computer from going to sleep longer than 30 or so seconds so it's a non-issue.

I did check the networking, no other computer can wake mine, the turn itself off to save power boxes are all ticked but unchecking them doesn't allow me to check the wake computer box.

I think, for now, I'm going to let this rest. Disabling Voicemeeter does consistently allow my computer to sleep so I'll take that as the issue. I sincerely appreciate your help on this. Thank you so much for sticking by!


No worries man. Whatever it takes to try to get it solved is what we try to do. I wish it was a more complete resolution, but sometimes a partial solution is better than none. There are some issues out there, cross compatibility problems when specific hardwares are used in the same machine, that I think for whatever reason simply do not HAVE a resolution. I think that goes for some softwares as well.