Question Windows 10 stuck on loading little dots keep going round and round

Dec 20, 2022
I have the following to my recollection
Asus ROG Strix X470-F
AMD Ryzen 5 2600X
GSKill Ripjaws 3200 2x8GB
Powercolor Red Devil RX 580 / 8GB
Inland SATA SSD 250 GB
Samsung 970 EVO NVME SSD 250GB
Operating System Windows 10 Pro

Computer was working fine a day before. I clicked "Power" / Sleep and put the system in sleep. When I tried to weak up the system I could see it powered up, but the screen monitor was blank (black , showing nothing) . Pressed the power button for 4 seconds and powered off the system. When I powered on again, it POSTs OK and starts loading Windows and gets stuck in the loading screen with the dots going round and round forever.

I booted from a Windows 10 USB, went into repair mode and for few days I tried every option available to recover.
  • system repair - does not work, every time I get the message that it could not perform a system repair.
  • system restore - found 2 restore points, restored to the further one, it goes through the whole restore process, same thing on restart gets stuck on loading Windows.
  • I removed the drives and connected one drive at a time - clean install of Windows 10 and issue still continue.
1 - when I install on any of the NVME SSDs on restart after install complete does not even goes to where you do the first configuration setup, is stuck on the same step of the dots going round and round
2 - when I installed on the SATA SSD, it did go through the first configuration setup, restart, and nothing , same dots going round and round.

When I started from the USB drive and went into the different repair menus I did opened the CMD mode and ran chkdsk on all these disks with no issues for any of them.
The only thing I could not run in CMD was the sfc scannow, with its options. It can not start the sfc scannow, even after I went in CMD and get the TrustedInstaller ( sc config trustedinstaller start= auto / Success/ net start trustedinstaller) - service started.
What else can I try before i get a new MB , CPU and build a new one?

One other issue to mention, and probably an important one, when I go in BIOS i can see the date in there is some date like year 3031. I changed it to current date , on the next boot , when I went to BIOS again, is shows again the year 3031 date. Any suggestions?


Sep 13, 2009
Doubt you need a new MB/CPU. BIOS date is strange, almost sounds like it has two BIOSes and you're changing the date in one but something else is wrong with it and causing it to not POST so the board is automatically switching to the other/backup one, which also has the wrong date. Did you try clearing CMOS (resetting BIOS) completely (power off, unplug, turn on while unplugged, press and hold reset button or use jumper)? Windows has issues with sleep, lots of people, myself included, have had issues where it won't resume, but it should have worked when you reset it. Might have corrupted something, but doing repair should work as should clean install of course, so not sure what's going on there. It sounds like maybe you're booting to one drive and installing on another drive, so it's trying to boot the broken install vs the fresh one. You can also try a live linux thumb drive to see if that will boot, to narrow down if there's an issue with the system or with the drive(s)/Windows. Also, how long are you waiting for the spinning dots? Maybe it just needs more time. Another thing to check is RAM, run memtest for a while to make sure there's no issues there.
Dec 20, 2022
I did a last attempt yesterday evening, I have replaced the CMOS battery (the one I took out from the motherboard, I checked it, and was completely dead); read somewhere that dead CMOS battery can give result in some weird system behavior. Once I did that, I booted again from a USB installation disk, went into the advance repair options, opened CMD, ran chkdsk /r, ran DISM.exe , ran sfc /scannow. Booted again, and the miracle happened, the system came back to life. Now I am installing drivers and software. Hope it stays alive.