Windows Delayed Write Failed

Not open for further replies.


Apr 7, 2005
This is the error I've been having.

Windows - Delayed Write Failed : Windows was unable to save all the data for the file [name_of_the_file_you_want_to_save].
The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

It usually happens when I'm doing several things at once and I try to copy or move a big file, or many small ones.

My system has:
Epox MF570SLI Motherboard
Athlon X2 3800+
G.SKILL 2GB (2 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 Memory
256MB GeForce 6600GT
Hard Drives (SATA):
1 x 250GB
1 x 320 GB
2 x 500 GB

Any of you knows how to solve this problem?
Thanks in advance!


Apr 7, 2005
I've been googling a lot about this and there is a lot of people that have the same problem.

Quoted from Microsoft:
Delayed Write Failure
Data corruption may occur if the Large System Cache feature is enabled in Windows XP. This problem does not occur on all systems. The key ingredients that lead to data corruption may include: • System Memory greater than 512 Meg. (1 gigabyte of RAM is common)
• Large NTFS disk volumes and multiple large volumes. (60-100 gigabyte hard drives possibly in RAID arrays)
• AGP graphics with large AGP resource requirements (AGP aperture greater than default)
• Large file transfers. This problem occurs when the computer runs out of system page table entries. Windows determines (at boot time) the default number of page table entries to assign, based on the amount of system memory available.
Doesn't that includes 100% of new desktops.

Are they trying to force Vista on us with this kind of bug.


Apr 7, 2005
Come on anybody has been able to solve this problem?

I googled it and found a lot of people having this problem but I've done many of the things they tried without any luck.

Thanks in advance for your help


Aug 7, 2007
I'm getting the same thing on BOTH of my new workstations with SATA drives when installing application software.
I've Googled the problem and answers range from failing hardware, to bad network connections. Here's what I've collected thus far:

Some common reasons for a delayed-write failure are:

1. Problems with a device driver, especially a SCSI or RAID device driver.

Some RAID device drivers are known to issue spurious "Delayed Write Failed"

errors in XP Service Pack 2. Most manufacturers have been alerted to this, so

check to make sure the disk drivers are up-to-date.

2. Cabling problems. A faulty or broken cable -- especially for an external

USB or Firewire enclosure—can generate this error. It can also happen if the

cable is too long, or if it is hooked up through a hub that isn't up to spec.

Another possible culprit is if you have a UDMA drive that requires an 80-pin

cable, and you are using a 40-pin cable.

3. SCSI termination errors. This has become less likely with the advent of

self-terminating SCSI hardware, but it shouldn't be counted out.

4. Media errors. This is the worst possible scenario -- essentially, drive

failure. If you can garner statistics on the drive via SMART (such as SMART &

Simple (, you may be

able to determine if there's a mechanical failure in the offing. Gibson

Research's SpinRite tool ( is also useful for assessing media

errors, but be warned: It may take a long time to do a thorough test.

5. BIOS settings on the computer are forcing faster UDMA modes than the drive

controller can handle. This is unlikely, especially with newer hardware (which

can support UDMA far more flexibly), but it can usually be fixed with a BIOS

upgrade, or by resetting the BIOS entries for the hard drives to auto-detect

settings. Devices set to UDMA Mode 6 that produce this error, for instance,

might need to be set to Mode 5.

6. Controller issues. I've observed that USB controllers that contend strongly

with other hardware can produce this error. In systems that have both "long"

and "short" PCI slots (i.e., 64-bit and 32-bit), try moving the USB controller

to the long slot. Older PCI cards will not fit in such a slot.

7. Memory parity issues. If the problem appears after installing new memory,

the memory in question may be faulty or not of the correct type for the

motherboard in question. (This may go hand-in-hand with other problems such as

random lockups, too.)

8. The LargeSystemCache Registry tweak and ATI video adapters. One peculiar

set of circumstances that has been observed on multiple machines with ATI

video adapters and more than 512MB of memory involves the LargeSystemCache

Registry setting, a DWORD entry found in

HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession ManagerMemory

Management. This setting governs the amount of memory set aside by the system

for certain kernel processes. If it's set to 1 (which allegedly improves

performance on systems with more than 512MB of memory), it can cause data

corruption on some systems, and produce the "Delayed Write Failed" error. Try

resetting it to 0 if it's been set.


My computer with a fresh clean install of XP Pro a few weeks ago was running

fine until I decided to look in Google for some "XP tweaking guide". I must

say that I'm a computer techincian in life so I know what was tweaking and I

also knew what I was looking for. I'm not that kind that change everything not

knowing what I'm doing.

So I read 2 guides online while performing some changes I wanted to my system

like turning off Indexing for example and disabling Automatic Update, etc. I

may have done about 15 changes in all, most of wich are very common.

Then I restarted the computer and started to get A LOT of Delayed Write Failed

Error messages. Often about C:\$Mft and also about all files the computer was

trying to touch.

I was a little on panic, I knew I would have to reformat clean install again

and I didn't wanted to do that until I figured out what the problem was. So I

began to search on Google with keywords, 15 minutes, half an hour, 1 hour

later I found enough informations to test something. BTW, I didn't liked what

Microsoft said about 40-wires and 80-wires cables hooked up to the hardrive

because I'm running a SATA WD360 Raptor and I haven't modified my BIOS at all


I reformatted and fresh installed XP. Then I ran RegEdit to go change

"LargeSystemCache" from 0 to 1. Restart, nothing happened. I ran RegEdit again

to put it back to 0.

Now I installed the ForceWare package because I'm running an Abit NF7-S v2.0

mobo. Then I ran RegEdit to go change "LargeSystemCache" from 0 to 1. Restart,

nothing happened. I ran RegEdit again to put it back to 0.

Finally, I installed the Catalyst 4.1 because there is an ATi All-in-Wonder

9600PRO inside the case. Then I ran RegEdit to go change "LargeSystemCache"

from 0 to 1. Restart, BANG! Delayed Write Failed! It was impossible to reran

RegEdit to set it back to 0 because the computer was so slow, hang, gave

error... I tried about 3 restart before waking up and try it in Safe Mode. Now

I was able to set it back to 0. Restart, and after a CHKDSK, all was fine


I took time to install Catalyst 4.2 over 4.1 and try again but the problem was

still there.

So, I still don't know why nobody else have tried that before to point out

exactly where the problem was. I looked around Google a lot but didn't find

any testing result close to that. I don't understand either WHY that happen

AFTER the ATi video driver were installed but I had a clue because many of you

were talking about ATi maybe being the problem.

So I hope that was helpfull for you. ATi and "LargeSystemCache" registry

setting are a no go. Don't bother tweaking that registry. *****Hopefully, all

tweaking guides over Internet will be updated to clarify this***** Now I just

hope a program or a driver cannot by itself change that setting. Can anyone

confirm why would a company need to change that setting anyway?

If you have spare time and another spare HD, I suggest you try the exact same

procedure and see if you get the same results. Clean install then immediatly

try to modify the "LargeSystemCache". If no problem, put it back to 0 and then

install the ATi driver and try again to modify "LargeSystemCache". If 2 or 3

more can confirm, it would be great.

I'll took another 1 hour to install again a fresh XP for the last time I hope.

Then 2-3 hours to set it back like it was, installing all programs again and

fine tune it all over again. But this time my "Ghost" hd would be ready. I was

just sitting between 2 computers because time was missing to fully migrate one

over the new one.


Application popup: Windows - Delayed Write Failed : Windows was unable to save

all the data for the file [name_of_the_file_you_want_to_save].

The data has been lost. This error may be caused by a failure of your computer

hardware or network connection. Please try to save this file elsewhere.

This problem occurs when the data redirector of a System flushes the contents

of the file, and writes to a file handle with read-only access instead of to a

file handle with write access.

When the redirector received an opportunistic lock break to none, it purged

the cache for the file, but did not uninitialize the cache for the file.
More Information:
The redirector also needed to purge and uninitialize when the set end of file

occurs because the opportunistic lock break is asynchronous. Because it did

not uninitialize the cache for the file, it wrote to the incorrect file



Warning: Serious problems might occur if you configure the registry

incorrectly by using the Registry Editor. Microsoft recommends that you create

a backup of your current registry before making changes.

1. Click Start, and then click Run.
2. In the Open box, type regedit, and then press ENTER.
3. In Registry Editor, locate the following subkey in the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet \Services\LanmanServer\Parameters
4. In the right pane, click EnableOplocks, and then press ENTER.
5. In the Value data box, type 0, and then press ENTER.
6. Quit Registry Editor.


I hope this helps. I'm working on the problem now on two new machines less than a week old.



Oct 8, 2007
Try This was the most recent USB driver hot fix I found, and it completely solved the DWF on $MFT problem I'd had fairly consistently on two different USB 2 connected drives. YMMV.


Feb 17, 2001
Have you tried to move your page file to another partition?

Drop your AGP Aperature down to 128 or 256, nothing higher.

I'd suspect either the page file is "System Managed" or too large, never too small. You don't really want System Managed because it'll use a set portion of space and probably make it too large.


Nov 5, 2007
If i'm not mistaken, I had this problem once. It prevented me from even logging into windows. The problem was having the system cache option on and something about the address of my ATI graphics card. The solution was to change the GPU's address. That FFFFFF thing. :) Though it may be caused by different factors for some (such as the OP has nVidia) but this was what happened with mine a few years ago IIRC.

HAHA, found my old posts about this error. This thread is long and may be of some help. As you can see this problem seems to crop up for different reasons. I had none of the system components that others did.

">> Re: "delayed Write failure" in WIN XP
Ok, I got some info. I did a little test and it appears that the fix described at this link is what works for me. Before reformatting, I decided to test this theory out. The fix instructs you to change the value of the registry entry "HKey_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SessionManager\MemoryManagement\SystemPages. The value as set (by ATI?) is "183000". The fix suggests changing it's value to "ffffffff". With the value set to "ffffffff" I enabled LargeSystemCache and restarted. No DWF errors upon startup. I then disabled LargeSystemCache and returned the SystemPages reg. entry value back to "183000" and restarted. No DWF errors upon startup there either. I then enabled LargeSystemCache, and left SystemPages value at "183000" and restarted, and BAM! DWF again. I took the time to jot down the error messages and they are as follows, and not exactly in order:

User init.exe - Application Error The application failed to initialize properly (0xc000142).
WINDOWS Delay Write Failed unable to save all the data for file C:\WINDOWS\System32\drivers
WINDOWS Delay Write Failed unable to save all the data for file C:\WINDOWS\System32
WINDOWS Delay Write Failed unable to save all the data for file C:\WINDOWS
WINDOWS Delay Write Failed unable to save all the data for file C:\$Mft
WINDOWS Delay Write Failed unable to save all the data for file C:\$Secure
WINDOWS Delay Write Failed unable to save all the data for file C:\WINDOWS\System32\config
WINDOWS Delay Write Failed unable to save all the data for file C:\Documents and Settings\NetworkService.NT Authority
WINDOWS Delay Write Failed unable to save all the data for file C:\Documents and Settings\"user name"
WINDOWS Delay Write Failed unable to save all the data for file C:\Documents and Settings\LocalSettings
WINDOWS Delay Write Failed unable to save all the data for file C:\SystemVolume Information\_restore {F124F14B-A013-43AD-B7B1-D4C234411580}
WINDOWS Delay Write Failed unable to save all the data for file C:\SystemVolume Information\_restore {F124F14B-A013-43AD-B7B1-D4C234411580}\RP5
Think that pretty much covers the errors lol

Now I went back to Safe mode again and adjusted the registry for "LargeSystemCache" turning it on, and changed the SystemPages registry value to "ffffffff", as per the ATI solution in the aforementioned link, and viola, the system started back up with no errors at all. So, (hopefully) for me, LargeSystemCache can be enabled without DWF errors if the SystemPages registry value is changed to "ffffffff" instead of"183000" Guess i'm off to reformat and reinstall now, and hope that this is truly the cause of my DWF errors, and subsequently hope it's the last I see of them. But this is the first time i've been able to create and undo the problem at will."

But I think the OP has a different version of this problem as did many others. The errors (above) were errors I recieved when trying to load windows and I was therefore not able to even make it ot the desktop, while others appear to be having this problem while in windows and trying to copy big files, or such.


I was having this problem and the way I resolved it was to make sure there was no system caching, either on the Windows side or the devices side (in my case it was a WD external hd and ipod. Then I cleared some space from my C: because it was pretty full. Then I increased my page file size to the maximum possible. Problem solved.


Jan 26, 2010
I was getting delayed write failed errors on windows XP. (Event 51 errors followed "An error was detected on device \Device\Harddisk2\D during a paging operation.")

I've got removable SCSIs, EXternal USB(leant to me just to copy a few MP3s) and DVD writer, (BOOT SATA never had any issues). All were showing the same symptoms on and off. SCSI kept Couldn't copy large files or even robocopy folders. But the external USB was the most predictable and would fail after a few MP3 copies!

I Uninstalled all related drivers and any drivers not being used(carefully I was using a USB mouse so had to use the Keyboard commands and run up Taskmgr before hand to reboot): Disk drivers, IDE, SCSI, CDrOM, USB... then rebooted twice (as the Windows required a 2nd reboot to fully re-install all drivers). Hey presto External USB is now clearly working just copied 8 GB of music with no problems!

(I surfed and surfed and didn't really find any useful articles all were too specific to a type disk or Microsoft patch. so I thought I put this up to help any one out there still using XP)

Hope this helps!


Feb 28, 2010
Hello All -
I work for a small to medium-sized company supporting about 250 windows clients running WinXP Pro SP3.

We have had a few folks encounter this issue lately. The following fix has consistently worked for each and every system:

1) Open Windows Explorer, right click My computer and click on Properties.

2) System Properties window will appear, click on Hardware tab and then click Device Manager.

Device Manager in Microsoft Windows

3) Expand Network adapters’ entry in Device Manager window, right click the network card that you want to change speed/duplex setting and click Properties.

speed and duplex change in Microsoft Windows to solve slow Internet

4) Go to Advanced tab of network card’s properties window, here you can locate the entry to check or change the speed/duplex setting, normally it can be Speed & Duplex, Link Speed & Duplex, Link Speed/Duplex Mode, etc. You can proceed to change the setting to Auto or other specific speed/duplex mode (10Mbps full duplex, 100Mbps half duplex, 1000Mbps half duplex, etc). Finally click OK and close all windows.

Note: Most of the time the network card should work well by having auto, auto mode or auto negotiation setting, but sometimes it can cause slow network or Internet access problem. If you know the speed/duplex mode of connected router/switches, you can set to specific speed/duplex setting and test it. If not sure, test on all different settings.

Note: For my fix, I set this variable to 1000Mbps full duplex. I think the "smaller" connection to the network is what caused the individual nodes to choke when trying to save large excel spreadsheets to network shares.

Hope this helps someone! :sol:


Jun 17, 2010
I just started getting this same error on a system that has been running for almost 6 months. I haven't made any major changes, except for swapping out some extra storage drives. I did have 1 drive recently crash, so I temporarily dumped about 300gb of data onto my OS drive (still leaving 100gb free). That is the only change that has been made to the system. All of a sudden, yesterday it hung up and I started getting these delayed write errors over and over again.

Where should I start with the troubleshooting? I wouldn't think it would be a graphics card issue since that hasn't changed. Maybe something to do with the pagefile or disk cache since the OS disk has much less space available than previous to when the issues began?
Not open for further replies.

Similar threads