Wireless mouse simply won't work?

Jan 2, 2019
4
0
10
0
So I bought a new mouse from Trust, and I can't get a refund because they said they can't for open products or products that still work but aren't compatible? (Even tho I swear it says it doesn't void warrant if its incompatible) But anyway irrelevant..

When I plug in the adapter and turn on the mouse it says setting up this device (windows notification) then it says its ready to use and that its working etc, but... it literally doesnt click, move the cursor or anything at all, it lights up like the mouse is on. So I see other people have the same problem, so I did EVERYTHING, I contacted Trust, no help, I replaced batteries, no help, I reinstalled all drivers including the USB drivers, the mouse drivers etc, nothing worked, I tried using other mouse drivers hoping they'd be compatible or something, not working. I have also tried using it on another device (just one) but that didnt work either. So I think I've tried everything.

Now, it is a USB 2.0 receiver, and all my usb ports are 3.0. But this should not affect it shouldn't it? Because its backwards compatible and my previous wireless mouse thats literally 10 years older than this new one, works perfectly fine and thats also usb 2.0. Windows seems to think it works perfect but it just doesnt, but when I do click troubleshoot on the device it does say try reinstalling on another USB port that isnt 3.0 incase thats the problem, when I move it to another usb 3.0 it says problem has been fixed! But it hasn't.

Sorry it is kind of long but I just wanted to insure to everyone that I have tried everything before coming here for help when even the manufacturer doesn't know whats up. It's just been driving me crazy because my other mouse has no right click or mouse3/scroll button click. Again just coming here to try find out if its completely useless before I go out and purchase another one. Thanks for reading and all help and suggestions are welcome!
 

Tumeden

Respectable
Oct 15, 2016
449
0
1,960
85
Seems like you about covered everything, have you tried several different USB ports on the computer, sometimes moving it from one to another 'fixes' simple things like that. 'for whatever reason'
 
Jan 2, 2019
4
0
10
0


yeah unfortunately that hasn't worked either, feelsbad. Thanks for the reply man.
 
Jan 2, 2019
4
0
10
0
Guys I may have found a solution that no one else has talked about on the internet. It turns out that maybe some devices have the drivers installed but they never actually apply them, when I go to devices and printers in control panel and properties of the new mouse , if you go and click driver details it will say there is no information / drivers are not loaded for this device. This got me real confused because I reinstalled them multiple times etc but maybe its struggling to apply it to the actual device. Because when I connected my old mouse and go to driver details, it locates me to two files in system32/drivers called mouclass and mouhid. Gonna try and see if I can load these drivers to the new one since both mouses seem to actually have the same date for the installed drivers. Hard to explain but hopefully you understand whoever else has this problem. Will update with results!
 

Vic 40

Titan
Herald
You can find the device in device manager? What if you right clik it there,click update drivers,use the "search on my pc" option and navigate to the folder in which the downloaded drivers are,click that one and choose/open this.
 
Jan 2, 2019
4
0
10
0


Yeah that doesn't work either unfortunately
 

ASK THE COMMUNITY

TRENDING THREADS