Question Witcher 3 Problems with Loading Textures

Apr 22, 2022
48
1
35
0
Hi all, I feel like it's kinda late for a question like this but I just got Witcher 3 from the summer sale and have wanted to try it out. Heard it has great graphics and I have a good pc so I went ahead and maxed out the graphics. Long story short I have been in Novigrad for a bit and I'm starting to get issues with textures not loading properly. It might be a more general problem tho, as the load times are longer than I feel they should be given my specs. My problems involve parts of the map being black in the minimap, which corresponds to the areas with either textures loading very slowly or flickering textures; I also have moments where the game will take 10 secs to load the next dialogue option, which is strange because it never happened when I started; and also loading a save takes maybe 2 minutes.

I have done some googling and most of the posts involve mods, which I do not have and do not know whether it will impact me specifically. Also, many of the problems involve slower ssds or hdd but I am using a PCIe gen 4 SSD (I know gaming does not really make a difference lanes but I got the SSD for free). Here are my specs:

CPU: 12600K
GPU: RTX 3080 FTW3
MOBO: Gigabyte z690i ddr4
RAM: Trident Z 3200
PSU: EVGA supernova 850w
SSD: WD Black 850 1TB

Temps have not been crazy, CPU around 55 and GPU around 70, SSDruns a little hotter at 80 if that makes a difference. Also have some videos of what I'm talking about. First one is the textures and the second is the dialogue taking time to load, which I feel like shouldn't happen. Thanks in advance for any help!


 

Eximo

Titan
Ambassador
Did you turn on Resizeable Bar? That may help with the textures.

Does seem like a decompression problem though, taking a long time to fetch the model for the tent or find a single line of dialogue.
 
Apr 22, 2022
48
1
35
0
Did you turn on Resizeable Bar? That may help with the textures.

Does seem like a decompression problem though, taking a long time to fetch the model for the tent or find a single line of dialogue.
Sorry I'm not entirely sure what resizeable bar is? And yes I find it strange that it has so much trouble finding a line of dialogue but sometimes no problems with all of novigrad.
 

Eximo

Titan
Ambassador
I see some texture flickering and this also appears to be distant object pop-in (although it's way too close).
Are you overclocking anything? If yes, reset to default (regardless of temps). Do you get any of this behavior with Time Spy or Fire Strike after you run them back to back at least 4 times?
 
Apr 22, 2022
48
1
35
0
I see some texture flickering and this also appears to be distant object pop-in (although it's way too close).
Are you overclocking anything? If yes, reset to default (regardless of temps). Do you get any of this behavior with Time Spy or Fire Strike after you run them back to back at least 4 times?
I have not really overclocked perse, but in precision x1 I had boost lock on for a bit and I have my own fan curve. Also, another issue I've had for a while is with nvlddmkm.sys file. Occasionally I will lose signal to the computer and would have to forcefully shut it down, wait a bit and restart computer to get signal again. It happens randomly and I can't exactly pinpoint when it will happen, but in event viewer I will either have rebooted from a bugcheck 0x116 or have event id 14 error, just no bsod. Also in my windows/system32/drivers folder I don't have the nvlddmkm.sys file, and I'm not sure how to resolve that because I just figured it out. Oh well this is probs for another thread, thanks for the help.
 
It looks like your have OS corruption/instability going on. This is most likely related to your gaming issues.
Have you tried stress testing the CPU/RAM/GPU or completely erasing the OS and reloading? (not just a repair install)
 

DSzymborski

Titan
Moderator
From your past threads, this seems to be an ongoing issue, very possibly OS related. I think these problems are likely going together and it's pointless to solve the Witcher 3 problem without searching for the underlying issue?

Have you done a full wipe and reinstall of Windows? Have you ever on this hardware?
 
Apr 22, 2022
48
1
35
0
It looks like your have OS corruption/instability going on. This is most likely related to your gaming issues.
Have you tried stress testing the CPU/RAM/GPU or completely erasing the OS and reloading? (not just a repair install)
So I built this sff build maybe 3 months ago and I had a similar problem, but I replaced the psu and it worked just fine up until a little while ago. I reinstalled windows after installing the new psu, and I stress tested cpu and gpu for temps, ran prime 95 and aida64 for maybe 2 hours each. I have not done ram, and I didn't consider reinstalling windows because the sfc scan did not return anything so I always thought windows was fine.
 
Apr 22, 2022
48
1
35
0
From your past threads, this seems to be an ongoing issue, very possibly OS related. I think these problems are likely going together and it's pointless to solve the Witcher 3 problem without searching for the underlying issue?

Have you done a full wipe and reinstall of Windows? Have you ever on this hardware?
I have not on this specific hardware, tho i reinstalled windows but not sure it's a full wipe as u say. Also, I do have a second SSD that idk if I should wipe if I were to do a full wipe because I did not last time.
 

DSzymborski

Titan
Moderator
I have not on this specific hardware, tho i reinstalled windows but not sure it's a full wipe as u say. Also, I do have a second SSD that idk if I should wipe if I were to do a full wipe because I did not last time.
If you haven't installed Windows on this specific hardware, then you've never really installed Windows on this machine (and that means a full one in which the current partitions are completely removed). Windows is not designed to be modular. Windows 10 will try to compensate when people cut corners, but awful, mysterious problems can popup days, weeks, and even months down the road. That's why it's always best to do it properly the first time.
 
Apr 22, 2022
48
1
35
0
If you haven't installed Windows on this specific hardware, then you've never really installed Windows on this machine (and that means a full one in which the current partitions are completely removed). Windows is not designed to be modular. Windows 10 will try to compensate when people cut corners, but awful, mysterious problems can popup days, weeks, and even months down the road. That's why it's always best to do it properly the first time.
Sure I'm willing to do a full reset to install windows. Could you point me to a guide which involves removing the partitions?
 

DSzymborski

Titan
Moderator
Sure I'm willing to do a full reset to install windows. Could you point me to a guide which involves removing the partitions?
 
So I built this sff build maybe 3 months ago and I had a similar problem, but I replaced the psu and it worked just fine up until a little while ago. I reinstalled windows after installing the new psu, and I stress tested cpu and gpu for temps, ran prime 95 and aida64 for maybe 2 hours each. I have not done ram, and I didn't consider reinstalling windows because the sfc scan did not return anything so I always thought windows was fine.
If you are having lock-up issues it could be hardware but lockups can also corrupt the OS very easily.
Run Furmark (or several loops of Time Spy/Fire Strike) on your GPU to see if you have GPU stability issues.
 
Apr 22, 2022
48
1
35
0
Quick update: I just did a clean install of windows, no drives except main boot drive and deleted all partitions. Everything was fine until I got into windows, and the same thing happened. I lose signal but PC is still running so I have to force restart computer. Currently trying integrated graphics and saw that I have a somewhat older graphics driver. Should I go to safe mode and ddu and install latest Nvidia driver?
 
Apr 22, 2022
48
1
35
0
If you are having lock-up issues it could be hardware but lockups can also corrupt the OS very easily.
Run Furmark (or several loops of Time Spy/Fire Strike) on your GPU to see if you have GPU stability issues.
Will try to test GPU but currently can't even stay in windows for more than 20 mins
 
Apr 22, 2022
48
1
35
0
Update 2: driver is installed, I can get into windows fine, but now the PC is rebooting from bugcheck 0x116 like before, and checking the memory dump using windbg still returns the same video tdr failure 116 with the module being nvlddmkm.sys
 
Apr 22, 2022
48
1
35
0
Just ran furmark multiple times, no problems at all. Currently running aida again and I got a message saying tdr was very low, and whether I wanted aida to fix it? So I clicked yes and the test is running. Will try the mfg drive tests after.
 

ASK THE COMMUNITY