XP doesn't recognize 2nd hard drive

G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

XP won't assign a drive letter to my second hard disk, even though it sees
the drive in the Device Manager. Any ideas.

Both disk have operating system on, and when switched, the system recognizes
and assigns letters to both drives, but when I switch them back, only one
drive is assigned a letter.

I've tried setting the Master/Slave and Cable Select, but that doesn't seem
to have any effect. Would having 2 CD/DVD set to Master/Slave affect the
primary IDE configuration?

Any ideas would be greatly appreciated.

Thanks

Mark
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Figuring that the drives are set to master/slave,dont use cable select,go to
run,
type:diskmgmt.msc In msc,L.click the un-lettered drive,go to
actions,all,select
make active and/or change drive letter and path,then asign it a letter.

"MChrist" wrote:

> XP won't assign a drive letter to my second hard disk, even though it sees
> the drive in the Device Manager. Any ideas.
>
> Both disk have operating system on, and when switched, the system recognizes
> and assigns letters to both drives, but when I switch them back, only one
> drive is assigned a letter.
>
> I've tried setting the Master/Slave and Cable Select, but that doesn't seem
> to have any effect. Would having 2 CD/DVD set to Master/Slave affect the
> primary IDE configuration?
>
> Any ideas would be greatly appreciated.
>
> Thanks
>
> Mark
 

anna

Distinguished
Apr 17, 2004
339
0
18,780
0
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

"MChrist" <MChrist@discussions.microsoft.com> wrote in message
news:267AF7E6-74B2-4F4D-B56D-71C900F14A7B@microsoft.com...
> XP won't assign a drive letter to my second hard disk, even though it sees
> the drive in the Device Manager. Any ideas.
>
> Both disk have operating system on, and when switched, the system
> recognizes
> and assigns letters to both drives, but when I switch them back, only one
> drive is assigned a letter.
>
> I've tried setting the Master/Slave and Cable Select, but that doesn't
> seem
> to have any effect. Would having 2 CD/DVD set to Master/Slave affect the
> primary IDE configuration?
>
> Any ideas would be greatly appreciated.
>
> Thanks
>
> Mark


Mark:
Please answer the following...
1. Specifically identify the make, model, and capacity of each HD.
2. You indicate that both drives are bootable, yes?
3. Each drive contains the XP OS, yes? Is one a clone of the other?
4. When you connect each drive alone, (without the other being connected),
presumably as Primary Master, each will boot OK?
5. If you connect both drives, one as PM and the other either as Slave to
the PM or on the secondary IDE channel, does the PM boot? And does the
system recognize the second drive in that situation? Or is there a problem
here.
6. Are you *absolutely* certain you've connected the drives properly and
they are jumpered correctly?
7. What do you see in Disk Management insofar as the status of these drives
and their drive letter assignment?
8. When you state the problem arises when you "switch" the drives. Could you
explain what you mean by "switching"? Are you physically changing the IDE
cable connections and jumpering configuration of these drives? Or are you
working with removable drives?

It might help if you would give more precise details at to the exact nature
of your problem. I'm not entirely clear exactly how this problem is
manifested.
Anna
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Anna and Andrew,

Thank you both for your responses. Unfortunately by the time I got your
responses, I had already solved the problem of getting the 2nd drive
recognized by using the recovery options in the XP Install.

Drastic measures in that I lost the contents of the drive, although I had
intended to format it anyway. Andrew, thanks for the diskmgmt.msc tip which
solved the lettering problem I had

Thanks again both of you.

Mark

"Andrew E." wrote:

> Figuring that the drives are set to master/slave,dont use cable select,go to
> run,
> type:diskmgmt.msc In msc,L.click the un-lettered drive,go to
> actions,all,select
> make active and/or change drive letter and path,then asign it a letter.
>
> "MChrist" wrote:
>
> > XP won't assign a drive letter to my second hard disk, even though it sees
> > the drive in the Device Manager. Any ideas.
> >
> > Both disk have operating system on, and when switched, the system recognizes
> > and assigns letters to both drives, but when I switch them back, only one
> > drive is assigned a letter.
> >
> > I've tried setting the Master/Slave and Cable Select, but that doesn't seem
> > to have any effect. Would having 2 CD/DVD set to Master/Slave affect the
> > primary IDE configuration?
> >
> > Any ideas would be greatly appreciated.
> >
> > Thanks
> >
> > Mark
 

Similar threads


ASK THE COMMUNITY