Question Zotac 3060 Dual Edge OC, No Display showing

Oct 4, 2022
2
0
10
0
I have recently upgraded from a 1050ti to a 3060, although the diplay ports and HDMI slot are not giving any display out for the 3060. Think I may have got a faulty 3060 GPU as my MSI motherboard shows the VGA light coming on and stays on. Computer still works perfectly fine when i plug my 1050ti back in, hence why I'm thinking it is a potential faulty card with the 3060. Although I'm not hugely over familiar with these, so could be missing something obvious out. Also the fans start on the 3060 when the pc turns on just no display.

Updated to the newest Bios. Lastest Nvidia Driver installed(although this was while my 1050ti was plugged in) so unsure if the driver would be different for the 3060 and I would need to go to Nvidia's website to download the specific 3060 GPU driver or do they all have the same Drivers effectively?

My system below is:
CPU: Ryzen 5 3600
MB: MSI x470gaming plus max
RAM: 2 x 8gb Corsair vengance 3200mhz
Storage: 1 TB Crucial SSD
PSU: Corsair CX 550M 80+ bronze
GPU: Nvidia Geforce 1050ti
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

PSU: Corsair CX 550M 80+ bronze
How old is the PSU in your build? Did you use DDU to uninstall all remnants of GPU drivers prior to removing the GTX1050Ti from your build?
 
Oct 4, 2022
2
0
10
0
Welcome to the forums, newcomer!

PSU: Corsair CX 550M 80+ bronze
How old is the PSU in your build? Did you use DDU to uninstall all remnants of GPU drivers prior to removing the GTX1050Ti from your build?

PSU is 3 years old.

And no I have not used DDU to uninstall previous GPU drivers before removing the 1050ti. I'll give that a blast and update the post.
 

ASK THE COMMUNITY