Question İ7 8700K and RTX 2060 FPS DROP

Jun 4, 2019
3
0
10
0
Hello, I am having a drop from an instant 110 fps to 25 fps when playing resident evil 2. I am starting to drop to fps at 50 fps after getting out at 110 fps for a while after stopping at 25 fps. I have this problem in every game. My english is not good.
Thanks in advance.

System;

  • Motherboard: Asus TUF Z370 PLUS Gaming
  • Graphic Card: ASUS ROG STRİX RTX 2060 OC
  • CPU: i7 8700k
  • RAM: Corsair 8 GB 2666 MHz single module
  • SSD: Samsung 850 EVO 250 GB
  • CPU Cooler: Hyper Tx3 evo
  • Case: Cooler Master Silencio 650 d Pure
  • Monitor: Asus VG248QE
  • Power: Couger CMX 700 Watt 80 plus
 
Last edited:

Darkbreeze

Titan
Moderator
If there are any steps listed here that you have not already done, it would be advisable to do so if for no other reason than to be able to say you've already done it and eliminate that possibility.



First,

make sure your motherboard has the MOST recent BIOS version installed. If it does not, then update. This solves a high number of issues even in cases where the release that is newer than yours makes no mention of improving graphics card or other hardware compatibility. They do not list every change they have made when they post a new BIOS release.


Second,

go to the product page for your motherboard on the manufacturer website. Download and install the latest driver versions for the chipset, storage controllers, audio and network adapters. Do not skip installing a newer driver just because you think it is not relevant to the problem you are having. The drivers for one device can often affect ALL other devices and a questionable driver release can cause instability in the OS itself. They don't release new drivers just for fun. If there is a new driver release for a component, there is a good reason for it. The same goes for BIOS updates.


IF you have other hardware installed or attached to the system that are not a part of the systems covered by the motherboard drivers, then go to the support page for THAT component and check to see if there are newer drivers available for that as well. If there are, install them.


Third,

Make sure your memory is running at the correct advertised speed in the BIOS. This may require that you set the memory to run at the XMP profile settings. Also, make sure you have the memory installed in the correct slots and that they are running in dual channel which you can check by installing CPU-Z and checking the Memory tab. For all modern motherboards that are dual channel memory architectures, from the last ten years at least, if you have two sticks installed they should be in the A2 (Called DDR4_1 on some boards) or B2 (Called DDR4_2 on some boards) which are ALWAYS the SECOND and FOURTH slots over from the CPU socket, counting TOWARDS the edge of the motherboard EXCEPT on boards that only have two memory slots total. In that case, if you have two modules it's not rocket science, but if you have only one, then install it in the A1 or DDR4_1 slot.


Fourth,

Make sure the problem is not just a bad cable or the wrong cable IF this is a no display issue. If it is NOT related to a lack of display signal, then skip to the next step.

This happens a lot. Try a different cable or a different TYPE of cable. Sometimes there can be issues with the monitor or card not supporting a specific specification such as HDMI 1.4 vs HDMI 2.0, or even an HDMI output stops working but the Displayport or DVI output still works fine on the graphics card. Always worth checking the cable and trying other cables because cables get run over, bent, bent pins or simply were cheap quality to begin with and something as simple as trying a different cable or different monitor might be all that is required to solve your issue.


The last thing we want to look at,

for now anyhow, is the graphics card drivers. Regardless of whether you "already installed the newest drivers" for your graphics card or not, it is OFTEN a good idea to do a CLEAN install of the graphics card drivers. Just installing over the old drivers OR trying to use what Nvidia and AMD consider a clean install is not good enough and does not usually give the same result as using the Display Driver Uninstaller utility. This has a very high success rate and is always worth a shot.


If you have had both Nvidia and AMD cards installed at any point on that operating system then you will want to run the DDU twice. Once for the old card drivers (ie, Nvidia or AMD) and again for the currently installed graphics card drivers (ie, AMD or Nvidia). So if you had an Nvidia card at some point in the past, run it first for Nvidia and then after that is complete, run it again for AMD if you currently have an AMD card installed.

 
Reactions: CirillaFionaER
Jun 4, 2019
3
0
10
0
If there are any steps listed here that you have not already done, it would be advisable to do so if for no other reason than to be able to say you've already done it and eliminate that possibility.



First,

make sure your motherboard has the MOST recent BIOS version installed. If it does not, then update. This solves a high number of issues even in cases where the release that is newer than yours makes no mention of improving graphics card or other hardware compatibility. They do not list every change they have made when they post a new BIOS release.


Second,

go to the product page for your motherboard on the manufacturer website. Download and install the latest driver versions for the chipset, storage controllers, audio and network adapters. Do not skip installing a newer driver just because you think it is not relevant to the problem you are having. The drivers for one device can often affect ALL other devices and a questionable driver release can cause instability in the OS itself. They don't release new drivers just for fun. If there is a new driver release for a component, there is a good reason for it. The same goes for BIOS updates.


IF you have other hardware installed or attached to the system that are not a part of the systems covered by the motherboard drivers, then go to the support page for THAT component and check to see if there are newer drivers available for that as well. If there are, install them.


Third,

Make sure your memory is running at the correct advertised speed in the BIOS. This may require that you set the memory to run at the XMP profile settings. Also, make sure you have the memory installed in the correct slots and that they are running in dual channel which you can check by installing CPU-Z and checking the Memory tab. For all modern motherboards that are dual channel memory architectures, from the last ten years at least, if you have two sticks installed they should be in the A2 (Called DDR4_1 on some boards) or B2 (Called DDR4_2 on some boards) which are ALWAYS the SECOND and FOURTH slots over from the CPU socket, counting TOWARDS the edge of the motherboard EXCEPT on boards that only have two memory slots total. In that case, if you have two modules it's not rocket science, but if you have only one, then install it in the A1 or DDR4_1 slot.


Fourth,

Make sure the problem is not just a bad cable or the wrong cable IF this is a no display issue. If it is NOT related to a lack of display signal, then skip to the next step.

This happens a lot. Try a different cable or a different TYPE of cable. Sometimes there can be issues with the monitor or card not supporting a specific specification such as HDMI 1.4 vs HDMI 2.0, or even an HDMI output stops working but the Displayport or DVI output still works fine on the graphics card. Always worth checking the cable and trying other cables because cables get run over, bent, bent pins or simply were cheap quality to begin with and something as simple as trying a different cable or different monitor might be all that is required to solve your issue.


The last thing we want to look at,

for now anyhow, is the graphics card drivers. Regardless of whether you "already installed the newest drivers" for your graphics card or not, it is OFTEN a good idea to do a CLEAN install of the graphics card drivers. Just installing over the old drivers OR trying to use what Nvidia and AMD consider a clean install is not good enough and does not usually give the same result as using the Display Driver Uninstaller utility. This has a very high success rate and is always worth a shot.


If you have had both Nvidia and AMD cards installed at any point on that operating system then you will want to run the DDU twice. Once for the old card drivers (ie, Nvidia or AMD) and again for the currently installed graphics card drivers (ie, AMD or Nvidia). So if you had an Nvidia card at some point in the past, run it first for Nvidia and then after that is complete, run it again for AMD if you currently have an AMD card installed.

All OK. My ram default frequency is 2666 Mhz. But i am using 2133 mhz. Because ,Cpu warming up at 2666mhz. The problem persists.
 
Jun 4, 2019
3
0
10
0
I turned on the turbo mode of cpu and I did RAM frequency 2666 MHz.

ı will change the cooler but gpu used %80. is this related to problem?
 
Last edited by a moderator:

Darkbreeze

Titan
Moderator
Probably not. Likely it just means you have fairly high graphical settings in whatever game you're playing.

You shouldn't need to "turn on" turbo mode, or anything else for that matter, related to CPU performance. Simply reset the BIOS to the default configuration, and get a better CPU cooler. You want a good 140mm cooler for that CPU. At least.
 
Reactions: CirillaFionaER

ASK THE COMMUNITY

TRENDING THREADS