Question AMD New Build Running Slowly

Jan 20, 2020
6
0
10
0
I recently built my own computer with the following specs:
  • CPU - AMD Ryzen 5 3600 3.6 GHz 6-Core Processor
  • Motherboard - MSI B450 TOMAHAWK ATX AM4 Motherboard
  • Memory - Corsair Vengeance LPX 16 GB (2 x 8 GB) DDR4-3200 Memory
  • Memory 2 - Intel 1TB SSD6
  • Storage - Seagate Barracuda Compute 2 TB 3.5" 7200RPM Internal Hard Drive
  • Video Card - Sapphire Radeon RX 5700 8 GB Video Card
  • Power Supply - Corsair TX550M
  • Case - NZXT H500i ATX Mid Tower Case (included this because i'm using only the stock fans from this case)
  • OS - Windows 10
I've been using this machine for only about three months so far but i've found ever since the first day, my pc has been running pretty slowly (relatively slow boot up times, windows explorer seems to lag quite a bit and i'm having to restart my computer at least once if I want to play something on steam, and lastly, code compiles/get interpreted extremely slowly when using certain IDEs). I feel like with these specs my computer should be running a lot quicker.
I should also probably add that my Windows is running through my mechanical disk drive so that could be one source of slowness but it seems unlikely that it would be causing these issues.
Any advice?
 
Jan 20, 2020
6
0
10
0
I pretty much just installed what came on the B450 disk.
I bought the HDD before I got the SSD so that's why. Is there any to do it without loosing data?

Interesting about the PSU... pcpartpicker said it was more than enough...
 

ASK THE COMMUNITY