[SOLVED] AMD Ryzen 4600G graphics driver won't install

badmem

Distinguished
Sep 15, 2012
2
0
18,510
0
I have an ASRock B450 Gaming-ITX/ac motherboard. I installed a Ryzen 5 4600G CPU. This is installed in a COOLERMASTER lite 130 Mini-ITX case. The 4600G is listed as compatible with the ITX board. I upgraded the BIOS to 4.40 as recommended on the ASRock website. I installed Windows 10 and connected the motherboard HDMI port to a Dell S3221QS monitor.
Windows installed the Microsoft Basic graphics driver and the monitor resolution is set to 1920x1080.
I've tried to install the AMD graphics driver which is supposed to support the CPU integrated graphics. The screen flickers and the PC freezes. I've reset the UEFI to default settings. I've downloaded the latest driver for Windows 10 from ASRock and AMD. I've updated to the latest UEFI 4.80. I've tried manually updating the Microsoft basic graphics driver by loading the driver from the unpacked AMD driver package. The driver shows as the RADEON driver, but it freezes the PC when it installs.
Any suggestions why this is happening and if there's a way to fix it. I want to get the integrated graphics working at a decent resolution in this mini-ITX PC. I'm not planning to play games, I just need it to make use of the monitor resolution and the built-in speakers.
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Out of curiosity, how did you manage to update the BISO to version 4.40? Source the GPU drivers from AMD's support site. Install said driver in an elevated command, i.e, Right click installer>Run as Adminsitrator. On a side note, where did you source the installer for your installation of Windows 10? What version(not edition) of Windows 10 are you working with?
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Out of curiosity, how did you manage to update the BISO to version 4.40? Source the GPU drivers from AMD's support site. Install said driver in an elevated command, i.e, Right click installer>Run as Adminsitrator. On a side note, where did you source the installer for your installation of Windows 10? What version(not edition) of Windows 10 are you working with?
 

badmem

Distinguished
Sep 15, 2012
2
0
18,510
0
Welcome to the forums, newcomer!

Out of curiosity, how did you manage to update the BISO to version 4.40? Source the GPU drivers from AMD's support site. Install said driver in an elevated command, i.e, Right click installer>Run as Adminsitrator. On a side note, where did you source the installer for your installation of Windows 10? What version(not edition) of Windows 10 are you working with?
The UEFI /BIOS was downloaded from the ASRock website. I downloaded the graphics driver from ASRock and also AMD. The driver was installed with Admin rights.
The version of Windows 10 was the problem. I had Windows 10 Pro - Version 1511 Build 10586.494.
After your post I manually updated Windows to Version 21H2 Build 19044.1288.
After the update finished Windows was running at 3840x2160 resolution with the AMD Radeon software installed. Graphics and audio through the monitor speakers are now working correctly.😀

Thank you
Lutfij
 

ASK THE COMMUNITY