Question ASUS TUF GAMING B460M-PLUS not working RAM

Aug 7, 2020
Recently I got a ASUS TUF GAMING B460M-PLUS motherboard, with an I5-10400F, a XPG SPECTRIX D41 16GB 3200MHz, and a ASUS AREZ RX 580.

But when I try to boot, it lights everything up, but it does not display a thing. It light up a orange LED where it is written DRAM. So I tried to change the memory to DIMM_B2 slot, and It worked for a while. But then, when I turned on to install the OS, it didn't boot again, same problem. Then after a few times trying to remove and switch slots, It worked again. But when I rebooted to install the OS again, the same thing.

After that, I tried with my friend's corsair vengeance memory, but the same thing. And I've tried my memory on his computer and it worked fine, so I thing it should be something with the Motherboard.

Thnaks for the help :)
Unfortunately, it is easy to damage the cpu socket if you did not drop the processor in cleanly.
Results are unpredictable, but ram issues seem common.
Take the processor out and examine the pins closely.
If you see a bent one, you can try to straighten it out using a needle.
A bent pin in the socket is not a valid RMA reason since it is commonly a user error.
That happens when you smoosh the processor around to get it seated.
You need to simply drop the cpu in cleanly.