Benq XR3501 Buzzing problem

Earmilk

Commendable
Mar 22, 2016
2
0
1,510
0
I have a concern about my XR3501 display which starts making a buzzing/static/electrical transformer like sound when i turn off the system.

When i cut the power to the transformer of the monitor the sounds stops. The sound comes from the monitor itself (not the powerbrick and the monitor does not have speakers, nor are any speakers connected to the system).

I run the monitor at 144hz and the sound also appears if i run it at 60hz. Its not a very big problem as you can only hear it for a while when the monitor is being turned off and it continues for quite a while, not taken the time for how long as it seems to take quite some time. I always cut 230v connection to the system by turning off the extension cord so the sound isnt really a problem but more of a concern if there is anything wrong with the monitor and if theres any fix or if anyone has an explenation for why this is.

Thanks for any answers regarding the problem!
 

ffg7

Distinguished
Moderator
as it uses a power adapter then the monitor does not have a power board in it only the video logic board. might be a bad or domed capacitor on that board is causing the problem. is it still under warranty?
 

Earmilk

Commendable
Mar 22, 2016
2
0
1,510
0


Yes it should still be under warranty even though it was bought as an demo product it should be covered by the same waranty as if it was bought new.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS