Question Bricked hdd

yann1211

Commendable
Mar 10, 2019
4
0
1,510
0
Hello, I am currently having problems with a seagate 2tb external hard drive. I have had this issue in the past, but I cant seem to figure out how to fix it this time. so, the drives purpose is to store games on my Xbox but when the drives reaches a certain capacity it fails and the Xbox wont see it anymore. At that point, I have to connect it to my pc and format it. this time, when I try to connect it to my PC and format it I cannot. the disk is unknown, not initialized and when I try to initialize it the following error pops up ("The request could not be performed because of an I/O device error."). I then tried connecting the drive directly with a SATA cable and things got worst. the drive was not recognized with 0MB capacity (capacity showing when connecting usb and Seagate information too)

i am at a lost here, I have also tried using a Seaboot usb and doing scans with their program but they fail.

NOTE: the drive was showing in device manager with SATA cable but as unknown drive.
 

JWNoctis

Upstanding
Jun 9, 2021
309
64
270
4
but when the drives reaches a certain capacity it fails and the Xbox wont see it anymore. At that point, I have to connect it to my pc and format it.
That was already not normal for a fully functional hard drive.

I'm afraid your drive has kicked the bucket, at last.
 
Last edited:

ASK THE COMMUNITY